Debian 6 + mehrere PHP-Versionen

10/03/2015 - 16:50 von Boris Hoeffgen | Report spam
Hallo,

ich habe auf unserem Debian 6 Server PHP 5.4 nach dieser Anleitung
(http://www.huschi.net/archiv/php-ve...trieb.html )
installiert.
Setze ich z.B. in einer .htaccess

ScriptAlias /bin-php54 /usr/bin/php54/

AddHandler php54-cgi .php54

funktioniert alles korrekt und der PHP Interpreter 5.4 wird verwendet, wenn die Dateien die Endung .php54 haben. Setze ich aber

ScriptAlias /bin-php54 /usr/bin/php54/
AddHandler php54-cgi .php

wird der Standard Interpreter PHP 5.3 aufgerufen, wenn alle Dateien die Endung .php haben.

Woran kann das liegen? Wie zwinge ich ihn 5.4 zu benutzen bzw. was mache ich falsch?

Gruß
Boris



Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/54FF1097.9040204@hjdt.de
 

Lesen sie die antworten

#1 Jochen Spieker
10/03/2015 - 18:00 | Warnen spam

Boris Hoeffgen:

ich habe auf unserem Debian 6 Server PHP 5.4 nach dieser Anleitung
(http://www.huschi.net/archiv/php-ve...trieb.html )
installiert.



Mutig! :) 5.4 wà¤re ja in Debian 7 (wheezy) enthalten und wird dort auch
(gelegentlich …) aktualisiert. Selbst kompilieren ist so gut wie immer
die schlechteste Option.

Setze ich z.B. in einer .htaccess

ScriptAlias /bin-php54 /usr/bin/php54/

AddHandler php54-cgi .php54

funktioniert alles korrekt und der PHP Interpreter 5.4 wird verwendet, wenn die Dateien die Endung .php54 haben. Setze ich aber

ScriptAlias /bin-php54 /usr/bin/php54/
AddHandler php54-cgi .php

wird der Standard Interpreter PHP 5.3 aufgerufen, wenn alle Dateien die Endung .php haben.

Woran kann das liegen? Wie zwinge ich ihn 5.4 zu benutzen bzw. was mache ich falsch?



Meine Glaskugel rà¤t, dass Dein AddHandler an anderer Stelle
à¼berschrieben wird. Schau mal in /etc/apache2/mods-available.

Testen kannst Du das recht leicht, indem Du Deine Zeilen wieder
rausnimmst und guckst, ob .php dann auch ordentlich mit PHP 5.3
aufgerufen wird. Wenn ja, dann muss das ja von irgendwo kommen.

J.
If I was a supermodel I would give all my cocaine to the socially
excluded.
[Agree] [Disagree]
<http://www.slowlydownward.com/NODAT...2.html>





Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen