[Debian lenny, Grub] Bootprobleme

24/10/2009 - 22:31 von Werner Holtfreter | Report spam
Hallo,

ich habe folgende Platten im System:

hdb
sda <-- Bootplatte
sdb
sdc

nachdem ich nach der Erstinstallation nicht booten konnte, habe ich
nochmal bei abgezogener hdb installiert und alles funktionierte,
auch nachdem hdb wieder angesteckt war.

Nun kam ein Kernelupdate und das Problem ist wieder da:
| Error 17, Cannot mount selected partition
Ich muss jedes Mal die erste Grub-Zeile interaktiv àndern von
"root (hd1,0)" auf "root (hd0,0)", dann làuft es.

device.map von der Erstinstallation, bei der ja hdb abgezogen war
(hd0) /dev/sda
(hd1) /dev/sdb
(hd2) /dev/sdc

habe ich nun geàndert auf
(hd0) /dev/hdb
(hd1) /dev/sda
(hd2) /dev/sdb
(hd3) /dev/sdc

trotzdem muss ich den gleichen Eingriff beim Booten machen, obwohl
hd1 doch eigentlich passen müsste, lt. folgender menu.lst:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
default 0
timeout 5
color cyan/blue white/blue

## ## End Default Options ##

title Debian GNU/Linux, kernel 2.6.26-2-amd64
root (hd1,0)
kernel /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda1 ro
initrd /boot/initrd.img-2.6.26-2-amd64

title Debian GNU/Linux, kernel 2.6.26-2-amd64 (single-user
mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda1 ro
single
initrd /boot/initrd.img-2.6.26-2-amd64

### END DEBIAN AUTOMAGIC KERNELS LIST
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In der BIOS-Boot-Reihenfolge liegt sda vor hdb, was aber offenbar
wirkungslos ist. Was làuft da falsch? Ist das Bootimage vielleicht
ungewollt auf hdb gelandet? (hdb, sdb und sdc bilden ein RAID 5 und
sollen nicht zum booten verwendet werden.)
Gruß Werner
http://www.manndat.de/fileadmin/Dok...melung.pdf
http://www.intact.ca/video.html <--VORSICHT HART
http://www.sextra.de/main.html?page!98
 

Lesen sie die antworten

#1 Martin Schnitkemper
24/10/2009 - 23:27 | Warnen spam
· Werner Holtfreter schrieb:

habe ich nun geàndert auf
(hd0) /dev/hdb
(hd1) /dev/sda
(hd2) /dev/sdb
(hd3) /dev/sdc

trotzdem muss ich den gleichen Eingriff beim Booten machen, obwohl
hd1 doch eigentlich passen müsste, lt. folgender menu.lst:



Ich meine mich erinnern zu können, dass nach Änderungen an device.map grub
neu installiert werden muss.

Martin.
.''`. OS: Debian GNU/Linux 5.0
: :' : Kernel: 2.6.26-2-686
`. `'` KDE: 3.5.10
`- Debian. Because it *must* work.

Ähnliche fragen