Forums Neueste Beiträge
 

Debian Netzboot mit PowerPC

28/09/2008 - 22:33 von Christian Garbs | Report spam
Mahlzeit!

Ich hab hier einen IBM PowerPC, genauer gesagt einen 43P Model 140, da
drin werkelt ein 604e mit 233 MHz. Laut dem, was ich im Internet
gefunden habe, ist das eine PReP-Maschine.

Nun soll auf die Kiste ein Debian Etch drauf. Das
Installationshandbuch[1] spricht von Netzboot, die Manifestdatei[2],
die unter [3] erwàhnt ist, verweist mich auf folgende Datei:

http://http.us.debian.org/debian/di...t/mini.iso

Diese hab ich per TFTP bereitgestellt. Die OpenFirmware versucht
einen Netboot, holt sich per BOOTP die Konfiguration und das Image
wird auch per TFTP geladen. Nur beim Starten des Images fliegt die
Kiste auf die Nase und vermeldet folgendes:

DEFAULT CATCH!, code=de9dbeef at %SRR0: 00604d50 %SRR1: 00083000

[4] verweist bei de9dbeef auf ein Firmware-Problem. Ein
"set-defaults" hab ich in der OpenFirmware schon ohne Besserung
abgesetzt.
Die NVRAM-Batterie physisch zu entfernen ist nicht ganz so einfach,
ich hab Angst, dass ich da was abbreche. Sehr komische Halterung.
Ich hab aber ein Stückchen Papier benutzt, um den einen Kontakt zu
isolieren, falls das geklappt hat, hab ich die fünf stromlosen Minuten
bereits hinter mir.
Gebracht hat's nichts.


Wie mache ich nun weiter?
Hab ich ein ernstes Problem?
Oder vielleicht doch nur das falsche Image am Start?

Gruß
Christian


[1] http://www.debian.org/releases/stab...06.html.en
[2] http://http.us.debian.org/debian/di...s/MANIFEST
[3] http://www.debian.org/releases/stab...here-files
[5] http://www.tek-tips.com/viewthread.cfm?qid7041&pageD4
Christian.Garbs.http://www.cgarbs.de
i LikE tO PlAy wITh My ShIFt kEy
 

Lesen sie die antworten

#1 Ulrich.Teichert
30/09/2008 - 20:38 | Warnen spam
In <gbopnj$k18$ Christian Garbs writes:

Mahlzeit!



Moin

Ich hab hier einen IBM PowerPC, genauer gesagt einen 43P Model 140, da
drin werkelt ein 604e mit 233 MHz. Laut dem, was ich im Internet
gefunden habe, ist das eine PReP-Maschine.



Richtig.

Nun soll auf die Kiste ein Debian Etch drauf. Das
Installationshandbuch[1] spricht von Netzboot, die Manifestdatei[2],
die unter [3] erwà¤hnt ist, verweist mich auf folgende Datei:

http://http.us.debian.org/debian/di...t/mini.iso

Diese hab ich per TFTP bereitgestellt. Die OpenFirmware versucht
einen Netboot, holt sich per BOOTP die Konfiguration und das Image
wird auch per TFTP geladen. Nur beim Starten des Images fliegt die
Kiste auf die Nase und vermeldet folgendes:

DEFAULT CATCH!, code=de9dbeef at %SRR0: 00604d50 %SRR1: 00083000



Ich glaube der PPC-prep Debian-Kernel làuft nicht auf der 43p 140. Richtig
getestet ist der nur auf Motorola PowerStack II.

[del]
Wie mache ich nun weiter?



Was besseres als: http://www.solinno.co.uk/7043-140/ hab' ich für die
43p bisher noch nicht gefunden.

Hab ich ein ernstes Problem?
Oder vielleicht doch nur das falsche Image am Start?



Ich hab' den PPC-prep Kernel von Debian auch auf meiner 43p 140 nicht zum
laufen gebracht. Aber dank den Anleitungen unter der obigen URL làuft
trotzdem ein Debian darauf ;-)

HTH,
Uli
Dipl. Inf. Ulrich Teichert|e-mail: | Listening to:
Stormweg 24 |Pale Bride (The Von Bondies), No Time (Statues),
24539 Neumuenster, Germany|Am Strand (Smoke Blow), Sacred Decay (The Estranged)

Ähnliche fragen