[Debian] Paket fehlt.

17/03/2011 - 07:54 von Michael Schütz | Report spam
Hallo Gruppe,

ich habe bekomme seit ein paar Tagen eine Fehlermeldung von meinem
Server, dass er clamav nicht aktualisieren kann.

-Zipp
~# apt-get install clamav
Paketlisten werden gelesen... Fertig
Abhàngigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu
lösen:

Die folgenden Pakete haben unerfüllte Abhàngigkeiten:
clamav : Hàngt ab von: libclamav6 (>= 0.97+dfsg) aber 0.96.5+dfsg-1.1
soll installiert werden
E: Beschàdigte Pakete
~# apt-get install libclamav6
Paketlisten werden gelesen... Fertig
Abhàngigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu
lösen:

Die folgenden Pakete haben unerfüllte Abhàngigkeiten:
libclamav6 : Hàngt ab von: libltdl3 (>= 1.5.2-2) ist aber nicht
installierbar
E: Beschàdigte Pakete
~# apt-get install libltdl3
Paketlisten werden gelesen... Fertig
Abhàngigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Paket libltdl3 ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Paket »libltdl3« hat keinen Installationskandidaten


Ich habe nicht gleich reagiert, weil ich dachte, dass der Fehler in den
Paketen schnell behoben wird, aber der Zustand ist nun schon rund eine
Woche so.
Kann mir dazu jemand etwas sagen und eventuell eine Lösung des Problems
anbieten?

Das laufende System ist ein Squeeze auf ARM (armel).

Danke,
Schultze

Die USA versuchen im Irak die Demokratie zu etablieren.
Wenn es gelingt, dann wollen sie es bei sich auch ausprobieren.
 

Lesen sie die antworten

#1 Matthias Grossmann
17/03/2011 - 10:24 | Warnen spam
Michael Schütz wrote:

ich habe bekomme seit ein paar Tagen eine Fehlermeldung von meinem
Server, dass er clamav nicht aktualisieren kann.

Die folgenden Pakete haben unerfüllte Abhàngigkeiten:
clamav : Hàngt ab von: libclamav6 (>= 0.97+dfsg) aber 0.96.5+dfsg-1.1
soll installiert werden

Das laufende System ist ein Squeeze auf ARM (armel).



Wenn ich mir die Abhàngigkeiten von clamav unter
http://packages.debian.org/squeeze/clamav bzw.
http://packages.debian.org/lenny-volatile/clamav ansehe, vermute ich, Dein
Server versucht, das clamav-Paket von lenny-volatile zu installieren. Sieh
mal in /etc/apt/sources.list nach, ob da noch ein Verweis auf lenny-volatile
drin steht, und entferne den ggfs.

Gruß,
Matthias

Ähnliche fragen