Debian Testing 2.6.24 und iwl3945

05/04/2008 - 15:51 von Thomas Sachs | Report spam
Hi an alle,

ich habe ein Dell Inspiron 6400 Notebook mit Intel3945-Wlan und bekomme die
Funkverbindung unter Debian Testing mit Kernel 2.6.24-1 zu meinem
Wlan-Router immer noch nicht hin. Firmware ist mit Hilfe anderer
Forenbeitràge installiert, die iwl3945-Module werden geladen (laut lsmod),
iwconfig zeigt mir die Schnittstelle wlan0 an. Ich kann wlan0 auch
konfigurieren, sie erhàlt auch eine IP-Adresse vom Router. Aber danach ist
Ende. Ich kann den Router weder anpingen, noch lassen sich Daten über die
Verbindung schicken. Kein Zugang zum Internet. Ach ja, konfigurieren kann
ich wlan0 nur manuell. Ein Konfiguration über /etc/network/interfaces rührt
nicht an, was ich auch nicht verstehe.
"ifconfig -a" zeigt mir seltsamerweise zusàtzlich auch noch eine
Schnittstelle wmaster0 an.

Wenn ich mein Notebook mit dem "alten" 22er Kernel starte und mit
den "alten" ipw-Sachen die Schnittstelle anschmeiße, funktionert alles
einwandfrei, bin daher wieder mit diesem Kernel unterwegs und online.

Momentan stehe ich auf dem Schlauch. Hat jemand nen Denkanstoß für mich, und
wenn ja: Welchen?

Danke schonmal für Eure Hilfe

Grüße

Thomas Sachs
Debian 4.0 Testing, Kernel 2.6.22, KDE 3.5.8
 

Lesen sie die antworten

#1 Thomas Bächler
05/04/2008 - 18:18 | Warnen spam
Thomas Sachs schrieb:
Hi an alle,

ich habe ein Dell Inspiron 6400 Notebook mit Intel3945-Wlan und bekomme die
Funkverbindung unter Debian Testing mit Kernel 2.6.24-1 zu meinem
Wlan-Router immer noch nicht hin. Firmware ist mit Hilfe anderer
Forenbeitràge installiert, die iwl3945-Module werden geladen (laut lsmod),
iwconfig zeigt mir die Schnittstelle wlan0 an. Ich kann wlan0 auch
konfigurieren, sie erhàlt auch eine IP-Adresse vom Router. Aber danach ist
Ende. Ich kann den Router weder anpingen, noch lassen sich Daten über die
Verbindung schicken. Kein Zugang zum Internet. Ach ja, konfigurieren kann
ich wlan0 nur manuell. Ein Konfiguration über /etc/network/interfaces rührt
nicht an, was ich auch nicht verstehe.



Benutzt du dhclient für das Erhalten der IP-Adresse? Poste doch bitte
mal ein paar Zeilen aus deinem syslog (/var/log/..., ich weiß nicht wie
die Dateien unter Debian genau heißen, aber messages.log, everything.log
oder syslog.log wàre interessant).
Auch die Ausgabe von ifconfig nachdem du die IP hast, wàre interessant.

"ifconfig -a" zeigt mir seltsamerweise zusàtzlich auch noch eine
Schnittstelle wmaster0 an.



Das ist nicht seltsam, das ist einfach so.

Momentan stehe ich auf dem Schlauch. Hat jemand nen Denkanstoß für mich, und
wenn ja: Welchen?



Ich habe eine Idee, würde aber gerne abwarten, ob sie hier wirklich
zutrifft.

Ähnliche fragen