Debian Wheezy: resolv.conf wird ueberschrieben

31/05/2014 - 18:41 von Sebastian Suchanek | Report spam
Hallo NG!

Nachdem ich meinen Server/Router mit Debian Wheezy komplett neu
aufgesetzt habe, zeigt die Kiste ein unschönes Eigenleben: Da
auf dem System u.a. ein Bind9 zur Verwaltung einer lokalen LAN-
Domain làuft, habe ich in /etc/resolv.conf entsprechend
"nameserver 10.1.0.1"[1] eingetragen.

Allerdings stehen nach jedem Re-Connect der DSL-Verbindung[2]
wieder zwei Nameserver der Telekom in der resolv.conf. :-(
Den ISC-DHCP-Client habe ich bereits deinstalliert[3] und in
/etc/ppp/peers/provider die Zeile "usepeerdns" auskommentiert.
Gebracht hat das allerdings bislang nichts...

Google spuckt mir dazu widersprüchliche Fundstücke aus. Die
einen meinen, man solle das Paket "resolvconf" installieren, die
anderen sagen, man solle es *de*installieren[4].
Hat jemand von Euch verbindliche Tips und Hinweise?


TIA,

Sebastian

_____
[1] 127.0.0.1 tàte es natürlich auch, allerdings dürfte das für
das vorliegende Problem keinen Unterschied machen.
[2] Eine weitere Funktion des Systems ist das (NAT)-Routen vom
LAN zum T-DSL-Anschluss. Realisiert ist das über zwei
getrennte Netzwerkkarten: Eine fürs LAN und eine fürs DSL,
also keine Basteleien mit Alias-Interfaces o.à.
[3] Der ISC-DHCP-*Server* muss wegen des angeschlossenen LANs
bleiben.
[4] Bislang ist es bei mir nicht installiert.
 

Lesen sie die antworten

#1 Paul Muster
31/05/2014 - 19:05 | Warnen spam
On 31.05.2014 18:41, Sebastian Suchanek wrote:

Allerdings stehen nach jedem Re-Connect der DSL-Verbindung[2]
wieder zwei Nameserver der Telekom in der resolv.conf. :-(
Den ISC-DHCP-Client habe ich bereits deinstalliert[3] und in
/etc/ppp/peers/provider die Zeile "usepeerdns" auskommentiert.
Gebracht hat das allerdings bislang nichts...

Google spuckt mir dazu widersprüchliche Fundstücke aus. Die
einen meinen, man solle das Paket "resolvconf" installieren, die
anderen sagen, man solle es *de*installieren[4].
Hat jemand von Euch verbindliche Tips und Hinweise?



Auf meinem Router-Server ist resolvconf auch _nicht_ installiert und da
bastelt kein "Tool" an der /etc/resolv.conf rum.
usepeerdns steht _nicht_ in der /etc/ppp/peers/<provider>.

Arbeitest du an der richtigen Datei in /etc/ppp/peers/ ? Nicht, dass da
zwei liegen - eine, die der pppd nutzt, und eine, an der du bastelst.


mfG Paul

Ähnliche fragen