defekte NTFS-Partition mounten

28/10/2007 - 22:42 von Christian Lorch | Report spam
Hallo,

ich kann eine Partition (IDE-Platte, NTFS, 3 Partitionen) nicht mounten.

mit myrescue habe ich schon versucht, die Platte soweit als möglich
auszulesen, Ergebnis war: ca. 150 Fehler. Die Platte macht defekte
Geràusche, es wird also wirklich etwas defekt sein, sie meldet sich aber
noch richtig beim Notebook an und die Partitionen 2 und 3 können ohne
Probleme gemountet und ausgelesen werden. Blöderweise sind die Daten auf
Partition 1.
Backup gibts schon, ist aber schon ein paar Tage alt, die Daten sind auch
nicht überwichtig, aber es interessiert mich jetzt, wie ich da evlt. noch
drankomme.


Beim loopbackmounten des myrescue-images kommt die gleiche Fehlermeldung wie
beim Mountversuch direkt von Platte:

noname:/media/120GB/lager # mount -o
loop /media/120GB/lager/1-2/p1 /media/test/
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error
Manchmal liefert das Syslog wertvolle Informationen – versuchen
Sie dmesg | tail oder so


Kann es wirklich sein, dass so rel. kleine Fehler die ganze Partition
plàtten? Werden wichtige Informationen nicht möglicherweise redundant
gespeichert?

In der myrescue manpage gibts noch den Hinweis vor dem mounten ein fsck
drüberlaufen zu lassen. Geht das bei "loop-back-images" auch? Ich hab keine
Option gefunden, dies zu veranlassen, mount mit ntfs-3g hat auch nicht
funktioniert (die Fehlermeldunghabe ich aber grad nicht mehr zur Hand).

Ich hàtte irgendwie erwartet, dass man ein Image bekommt, was teilweise ok
ist, teilweise nicht, aber nicht einen "Totalausfall". Die Programme und
Windows auf der Platte jucken ja eh nicht, kann ja auch sein, dass dort der
Hauptfehler liegt und nicht in C:\Dokumente und Einstellungen blablabla :-)


Ich hoffe, jemand hat noch Hinweise für mich. Andere Programme, spezielle
Optionen, etc.


schönen Abend noch,

Christian




Christian Lorch - der nett.Zwerg-Berater
 

Lesen sie die antworten

#1 g.fink
29/10/2007 - 06:40 | Warnen spam
In article <fg2vor$2es$,
Christian Lorch writes:
Hallo,

ich kann eine Partition (IDE-Platte, NTFS, 3 Partitionen) nicht mounten.


noname:/media/120GB/lager # mount -o
loop /media/120GB/lager/1-2/p1 /media/test/
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error
Manchmal liefert das Syslog wertvolle Informationen – versuchen
Sie dmesg | tail oder so



versuchs mal zusàtzlich mit -t ntfs
Oder falls du ein anderes ntfs-system hast nem entsprechenden befehl.
(ntfsmount ntfs3g )

MFG Gernot

Ähnliche fragen