Designer vergisst Einstellung

20/09/2007 - 14:46 von Marcus Schaefer | Report spam
Hallo,

ich habe eine Usercontrol die im wesentlichen eine Label-Control und eine
TextBox-Control vereint, so dass ich eine TextBox mit Überschrift erhalte.
Nun habe ich das interessante Phànomen (nur auf einem Formular des Projekt!),
dass ich im Designer bestimmte Properties dieser UserControl setze und diese
auch so im Designer angezeigt werden. Wenn ich das Programm starte und das
Formular anzeigen lassen, sind die Einstellung allerdings wieder auf die
Standardwerte zurückgesetzt. Auch der Designer zeigt nach beenden des
Programm nicht mehr die von mir gesetzten Property-Werte an.

Ich hab' leider keine Idee woher dieses kommen kann.

Marcus
 

Lesen sie die antworten

#1 Peter Fleischer
20/09/2007 - 21:07 | Warnen spam
Marcus Schaefer wrote:

ich habe eine Usercontrol die im wesentlichen eine Label-Control und
eine TextBox-Control vereint, so dass ich eine TextBox mit
Überschrift erhalte. Nun habe ich das interessante Phànomen (nur auf
einem Formular des Projekt!), dass ich im Designer bestimmte
Properties dieser UserControl setze und diese auch so im Designer
angezeigt werden. Wenn ich das Programm starte und das Formular
anzeigen lassen, sind die Einstellung allerdings wieder auf die
Standardwerte zurückgesetzt. Auch der Designer zeigt nach beenden des
Programm nicht mehr die von mir gesetzten Property-Werte an.

Ich hab' leider keine Idee woher dieses kommen kann.



Hi Marcus,
schau dir mal den vom Designer generierten Code an und vergleiche mit den
Controls, wo es funktioniert. Vielleicht fehlt ein Attribut bzw. ist falsch
gesetzt.

Viele Grüße

Peter

Ähnliche fragen