/dev/mapper/sdb1_crypt_unformatted

31/10/2012 - 16:49 von Holger Marzen | Report spam
Hallo,

in meinem PC mit Xubuntu 11.10 hab ich eine zweite Platte gesteckt. Das
Betriebssystem ist auf der ersten Platte mit gecryptetem LVM. Da gebe
ich beim Booten das Kennwort ein.

Die zweite Platte habe ich von Hand partitioniert, mit LUKS konfiguriert
und ein ext4-FS eingerichtet. Das Kennwort wird aus der Datei
/etc/luks_key_data.txt gelesen, die ja bereits auf einem gecrypteten
Device liegt. Meine /etc/crypttab sieht so aus:

|sda5_crypt UUID=cffb089c-2e63-4e46-b008-c046c94c2367 none luks
|sdb1_crypt UUID=edcd4605-e73a-412f-9463-c86dc5d83a94 /etc/luks_key_data.txt luks,noearly

Die sda5_crypt beherbergt die alte Installation, die sdb1_crypt das neue
ext4-FS, das in der /etc/fstab auf /data gemountet wird:

|proc /proc proc nodev,noexec,nosuid 0 0
|/dev/mapper/regen-root / ext4 errors=remount-ro 0 1
|UUIDp8b92b4-278f-4b3c-a529-471860f50870 /boot ext2 defaults 0 2
|/dev/mapper/regen-swap_1 none swap sw 0 0
|UUID=8cadb964-ec1f-491d-b5ed-4098a6e358d6 /data ext4 defaults 0 2

Soweit, so gut. Nach dem Einfügen von "noearly" bootet der PC wie er
soll und mountet das gecryptete FS nach /data. Aber wenn ich df aufrufe,
sehe ich nicht sdb1_crypt sondern sdb1_crypt_unformatted:

|hm@regen:~$ cd /data
|hm@regen:/data$ df .
|Dateisystem 1K‐Blöcke Benutzt Verfügbar Ben% Eingehàngt auf
|/dev/mapper/sdb1_crypt_unformatted
| 246133236 71319188 162311196 31% /data

Unmounte und mounte ich das Filesystem von Hand, steht sdb1_crypt als Device:

|root@regen:~# umount /data
|root@regen:~# mount /data
|root@regen:~# cd /data
|root@regen:/data# df .
|Dateisystem 1K‐Blöcke Benutzt Verfügbar Ben% Eingehàngt auf
|/dev/mapper/sdb1_crypt
| 246133236 71319188 162311196 31% /data

Wie làsst sich dieses Verhalten erklàren?
 

Lesen sie die antworten

#1 Holger Marzen
31/10/2012 - 16:51 | Warnen spam
* On Wed, 31 Oct 2012 15:49:39 +0000 (UTC), Holger Marzen wrote:

Soweit, so gut. Nach dem Einfügen von "noearly" bootet der PC wie er
soll und mountet das gecryptete FS nach /data. Aber wenn ich df aufrufe,
sehe ich nicht sdb1_crypt sondern sdb1_crypt_unformatted:

|:~$ cd /data
|:/data$ df .
|Dateisystem 1K‐Blöcke Benutzt Verfügbar Ben% Eingehàngt auf
|/dev/mapper/sdb1_crypt_unformatted
| 246133236 71319188 162311196 31% /data



Hoppala, aber auch nicht nach jedem Boot. Da soll sich mal einer einen
Reim drauf machen.

Ähnliche fragen