DHCP klappt, aber danach network unreachable

22/10/2007 - 12:27 von Michael Gerhards | Report spam
Hallo!

Ich habe hier ein Problem, dessen Ursache ich noch nicht genau
einkreisen kann, deshalb X-Post nach dcoub und dcounm; F'Up ist gesetzt
nach dcounm, bitte gegebenenfalls àndern!

Mein kleines Netzwerk hier ist folgendermaßen aufgebaut:
Server (192.168.1.10) unter FreeBSD 6.2, der u.a. als Internet-Router
(DSL-Zugang über PPPoE) und lokaler DNS-Server (dnsmasq) dient.

Client1 unter FreeBSD 6.2 und
Client2 unter WinXP

Gestern abend habe ich Client1 und Client2 heruntergefahren und vom Netz
getrennt; der Server lief über Nacht. Heute morgen habe ich dann Client1
und Client2 wieder gestartet mit dem Ergebnis, daß unter Client2 (WinXP)
alles wie gehabt funktioniert - unter Client1 (FreeBSD) ist aber das
gesamte Netzwerk nicht verfügbar.

Ich habe dann auf Client1 folgendes versucht:
/etc/rc.d/netif restart
sk0: no link got link
DHCPREQUEST on sk0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.10
bound to 192.168.1.134 -- renewal in 43200 seconds
sk0: flagsˆ43<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=b<RXCSUM,TXCSUM,VLAN_MTU>
inet 192.168.1.134 netmask 0xffffffff broadcast 192.168.1.255
ether 00:11:d8:ca:ed:43
media: Ethernet autoselect (100baseTX <full-duplex, flag0, flag1>)
status: active

/etc/rc.d/routing restart
route: wirting to routing socket: Network is unreachable
add net default: gateway 192.168.1.10: Network is unreachable


Von einer INSERT-CD gebootet (Live-CD auf Knoppix-Basis) ergibt sich das
gleiche Bild - die Netzwerkkarte bekommt eine IP-Adresse per DHCP, aber
danach ist das Netzwerk plötzlich "unreachable".

Wo könnte es hier hàngen? Physikalisch müßte meiner Meinung nach alles
okay sein, sonst kàme ja der DHCPREQUEST garnicht durch. Aber die
INSERT-CD liefert den gleichen Fehler, und der klingt auch nicht
unbedingt so, als wenn es am Server hàngen würde.

Hat jemand von Euch irgendwelche Tipps, wie ich das Problem weiter
eingrenzen könnte? Oder evtl. schon einen konkreten Verdacht? Ich bin
langsam ziemlich ratlos...

Vielen Dank schonmal im voraus,

Michael
 

Lesen sie die antworten

#1 Michael Gerhards
22/10/2007 - 14:07 | Warnen spam
On Mon, 22 Oct 2007 12:27:53 +0200, Michael Gerhards wrote:

Ich habe hier ein Problem, dessen Ursache ich noch nicht genau
einkreisen kann, deshalb X-Post nach dcoub und dcounm; F'Up ist gesetzt
nach dcounm, bitte gegebenenfalls àndern!


(...)
Gestern abend habe ich Client1 und Client2 heruntergefahren und vom Netz
getrennt; der Server lief über Nacht. Heute morgen habe ich dann Client1
und Client2 wieder gestartet mit dem Ergebnis, daß unter Client2 (WinXP)
alles wie gehabt funktioniert - unter Client1 (FreeBSD) ist aber das
gesamte Netzwerk nicht verfügbar.



Nachtrag:
Ich habe hier noch ein KNOPPIX 5.1.1 gefunden und testweise auf Client1
gebootet. IP-Adresse wird über DHCP korrekt zugewiesen und mittels

route add -net 192.168.1.0 netmask 255.255.255.0 eth2
route add default 192.168.1.10

kann ich dann auch erfolgreich einen ping absetzen (sowohl lokal als
auch ins Internet, Namensauflösung über DNS funktioniert auch). Aber es
ist mir mit KNOPPIX nicht möglich, irgendwelche WWW-Seiten vernünftig zu
öffnen; es werden bestenfalls Bruchstücke übertragen.
IPTRAF zeigt mir Übertragungsraten von 0.xx kbit/sec an.

Wo könnte es dort hàngen?

Vielen Dank schonmal für alle Tips,

Michael

Ähnliche fragen