Diagramm mit 2 Kurven aus 1 Datenbereich? (Diagramm-Profi gesucht)

07/11/2007 - 18:11 von Markus | Report spam
Hallo,
ich kàmpfe schon seit einigen Tagen mit verschiedenen Excel-Tabellen,
deren Daten als Diagramm dargestellt werden sollen.
Das Problem: Wie làsst sich ein Excel-Diagramm mit mehreren Kurven
erstellen, die aber beide den gleichen Datenbereich verwenden (Excel
2003 oder 2007)?
Beispiel (stark vereinfacht):
Datum Kunde Umsatz
07.11.06 Maier 9.000,00 €
08.11.06 Maier 5.100,00 €
09.11.06 Müller 5.600,00 €
10.11.06 Müller 600,00 €
11.11.06 Maier 3.900,00 €
12.11.06 Müller 7.800,00 €
13.11.06 Maier 1.100,00 €
14.11.06 Müller 6.000,00 €
15.11.06 Müller 5.800,00 €
16.11.06 Maier 8.200,00 €
Ergebnis soll ein Diagramm sein, das für jeden Kunden eine Kurve
(Diagrammtyp "Linie") enthàlt, aus der die Umsatzentwicklung dieses
Kunden vom 07.11. bis 16.11. hervorgeht. Jede Kurve müsste sich
sozusagen "ihre" Daten aus dieser Liste "heraussuchen" (wie z.B. bei
Pivot-Tabellen oder "SummeWenn").
Wenn man die Daten nach Kunden sortiert und dann im Diagramm mühsam
mehrere Datenreihen erstellt + jeweils die entsprechenden Bereiche
markiert, funktioniert das zwar - ist aber viel zu aufwendig. (Wie
gesagt, dies ist nur ein stark vereinfachtes Beispiel, außerdem werden
die Daten hàufiger aktualisiert.)
Hat jemand eine Ahnung, wie man das (ohne Makroprogrammierung)
vereinfachen könnte?
 

Lesen sie die antworten

#1 Beverly
07/11/2007 - 19:29 | Warnen spam
Hi Makus,

löse das Problem mit einer Hilfstabelle. Angenommen, deine Daten stehen in
den Spalten A:C beginnend ab Zeile 2. Schreibe in D1 Maier und in E1 Müller.
In D2 die Formel =WENN($B2=D$1;$C2;#NV) und in E2 die Formel
=WENN($B2=E$1;$C2;#NV) und ziehe beide nach unten bis zur letzten Datenzeile.
Das Diagramm erstellst du aus den Spalten D und E. Markiere dann das Diagramm
-> Extras -> Optionen -> Diagramm und aktiviere Leere Zellen: werden
interpoliert.

Bis spàter,
Karin

"Markus" wrote:

Hallo,
ich kàmpfe schon seit einigen Tagen mit verschiedenen Excel-Tabellen,
deren Daten als Diagramm dargestellt werden sollen.
Das Problem: Wie làsst sich ein Excel-Diagramm mit mehreren Kurven
erstellen, die aber beide den gleichen Datenbereich verwenden (Excel
2003 oder 2007)?
Beispiel (stark vereinfacht):
Datum Kunde Umsatz
07.11.06 Maier 9.000,00 €
08.11.06 Maier 5.100,00 €
09.11.06 Müller 5.600,00 €
10.11.06 Müller 600,00 €
11.11.06 Maier 3.900,00 €
12.11.06 Müller 7.800,00 €
13.11.06 Maier 1.100,00 €
14.11.06 Müller 6.000,00 €
15.11.06 Müller 5.800,00 €
16.11.06 Maier 8.200,00 €
Ergebnis soll ein Diagramm sein, das für jeden Kunden eine Kurve
(Diagrammtyp "Linie") enthàlt, aus der die Umsatzentwicklung dieses
Kunden vom 07.11. bis 16.11. hervorgeht. Jede Kurve müsste sich
sozusagen "ihre" Daten aus dieser Liste "heraussuchen" (wie z.B. bei
Pivot-Tabellen oder "SummeWenn").
Wenn man die Daten nach Kunden sortiert und dann im Diagramm mühsam
mehrere Datenreihen erstellt + jeweils die entsprechenden Bereiche
markiert, funktioniert das zwar - ist aber viel zu aufwendig. (Wie
gesagt, dies ist nur ein stark vereinfachtes Beispiel, außerdem werden
die Daten hàufiger aktualisiert.)
Hat jemand eine Ahnung, wie man das (ohne Makroprogrammierung)
vereinfachen könnte?


Ähnliche fragen