Forums Neueste Beiträge
 

DIAMEX ALL AVR ISP und AVRStudio

16/10/2012 - 21:26 von Johannes Schöller | Report spam
Hallo,

Ich bin hier noch am verzweifeln.
Habe von Reichelt den DIAMEX ALL AVR ISP Programmer um einen XMega zu
programmieren (letzter FW-Stand 1.3.0).

Wenn ich im AVRStudio (5.1.208) unter Tools=>AVR Programming aufrufe und
die Device ID auslesen möchte, so kommt die Fehlermeldung "Unable to
enter programming mode. Verify interface settings, target power and
connections to the target device." Wenn man auf Details geht kommt noch
folgender Zusatztext: "Failed to enter programming mode. Error status
received from tool: Result received is 0x01."

Wenn ich aus WinAVR make program aufrufe (also über avrdude), so
funktioniert das Programmieren, etc. fehlerfrei! Auch das Auslesen der
Device ID.

Der Programmer funktioniert also. Auf dem letzten Board hatte ich
ebenfalls einen XMega, da hat auch AVRStudio einwandfrei funktioniert.
Die Beschaltung am PDI-Interface ist gleich wie damals. (Pullup 10k von
PDI_CLK auf VCC=3V3).

Habt Ihr noch Ideen? Mir gehen sie leider gerade aus...

Viele Grüße,
Johannes
 

Lesen sie die antworten

#1 Johannes Schöller
17/10/2012 - 07:58 | Warnen spam
Hallo,

Habt Ihr noch Ideen? Mir gehen sie leider gerade aus...



Hat sich erledigt, nach Firmware-Update des DIAMEX ALL AVR ISP
Programmer auf Version 1.6.0 (siehe 1) funktioniert es nun auch mit
AVRStudio. Schade dass Reichelt immer noch die "alte" 1.3.0 Firmware zum
Download anbietet.

Viele Grüße,
Johannes

1) http://forum.diamex.de/content.php?...erger%E4te

Ähnliche fragen