Dienst will nicht automatisch starten

29/01/2008 - 14:06 von Andreas Froebel | Report spam
Hallo.

Ich habe einen Dienst geschrieben (VS 2005, Account=LocalSystem) und den
auch meiner Meinung nach ordentlich bei Windows (2000 SP4) registriert
(Installutil.exe).
Das Problem ist, ich weiß nicht, wieso der Dienst nicht automatisch beim
Starten von Windows gestartet wird, Starttyp ist auf Automatisch gestellt.
Es tritt kein Fehler auf, in den Ereignisprotokollen wird kein Eintrag
angezeigt und wenn ich den Dienst manuell starte geht das auch ohne
Probleme.

Hat jemand eine Idee, wieso der Dienst nicht automatisch startet?

Gruß A.Froebel
 

Lesen sie die antworten

#1 Stefan Simon
29/01/2008 - 15:18 | Warnen spam
"Andreas Froebel" schrieb im Newsbeitrag
news:fnn8cl$8gd$
Hallo.

Ich habe einen Dienst geschrieben (VS 2005, Account=LocalSystem) und den
auch meiner Meinung nach ordentlich bei Windows (2000 SP4) registriert
(Installutil.exe).
Das Problem ist, ich weiß nicht, wieso der Dienst nicht automatisch beim
Starten von Windows gestartet wird, Starttyp ist auf Automatisch gestellt.
Es tritt kein Fehler auf, in den Ereignisprotokollen wird kein Eintrag
angezeigt und wenn ich den Dienst manuell starte geht das auch ohne
Probleme.

Hat jemand eine Idee, wieso der Dienst nicht automatisch startet?



Klingt, als wàre eine Abhàngigkeit für den erfolgreichen Start nicht
erfüllt. Angenommen, dein Dienst greift auf das Netzwerk zu, der
Netzwerkdienst wurde aber noch nicht gestartet, dann schlàgt der Start
deines Dienstes fehl. Beim Manuellen Start làuft der Netzwerkdienst, deshalb
funktioniert das nun. Wenn dein Dienst also irgendwelche Ressourcen
benötigt, musst du sicherstellen, das dein Dienst erst nach den Diensten,
von denen er abhàngig ist, gestartet wird.

Stefan

Ähnliche fragen