dist-upgrade squeeze -> wheezy schlug fehl

14/06/2013 - 13:19 von Magnus Warker | Report spam
Hallo,

auf einem Debian-Rechner schlug das Upgrade von Squeeze nach Wheezy fehl.

$ apt-get update (OK)
$ apt-get upgrade (OK)
$ apt-get dist-upgrade
...
E: Could not perform immediate configuration on 'default-jre'. Please
see man 5 apt.conf under APT::Immediate-Configure for details. (2)

Die Suche im Netz ergab als eine Lösung, zunàchst die Pakete dpkg, apt
und linux-image-* zu installieren, aber auch das schlug fehl:

$ apt-get install dpkg apt linux-image-2.6-686
...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
initscripts : Breaks: nfs-common (< 1:1.2.5-3) but 1:1.2.2-4squeeze2
is to be installed
libgnome-keyring0 : Breaks: gnome-keyring (< 3.0) but 2.30.3-5 is to
be installed
network-manager : Recommends: crda but it is not going to be installed
Breaks: network-manager-gnome (< 0.9) but 0.8.1-2 is
to be installed
E: Broken packages

Was kann ich noch tun?

Danke
Magnus

This is Unix-Land. In quiet nights, you can hear the Windows machines
reboot.
 

Lesen sie die antworten

#1 Marcel Müller
14/06/2013 - 13:54 | Warnen spam
Hallo,

On 14.06.2013 13:19, Magnus Warker wrote:
auf einem Debian-Rechner schlug das Upgrade von Squeeze nach Wheezy fehl.

$ apt-get update (OK)
$ apt-get upgrade (OK)
$ apt-get dist-upgrade



Es gibt eine step by step Anleitung, wie man bei einem Upgrade auf
wheezy vorgehen soll. Es sind definitiv mehr Schritte als die drei.

Die Suche im Netz ergab als eine Lösung, zunàchst die Pakete dpkg, apt
und linux-image-* zu installieren, aber auch das schlug fehl:

$ apt-get install dpkg apt linux-image-2.6-686



Was soll das werden? - Wheezy hat einen 3-er Kernel.

Es gab AFAIR wechselseitige Abhàngigkeiten zwischen Kernel und udev, die
gelöst werden müssen.

The following packages have unmet dependencies:
initscripts : Breaks: nfs-common (< 1:1.2.5-3) but 1:1.2.2-4squeeze2
is to be installed
libgnome-keyring0 : Breaks: gnome-keyring (< 3.0) but 2.30.3-5 is to
be installed
network-manager : Recommends: crda but it is not going to be installed
Breaks: network-manager-gnome (< 0.9) but 0.8.1-2 is
to be installed
E: Broken packages



Du hast einiges schon auf Wheezy hoch gezogen. Jetzt wolltest Du zurück.

Was kann ich noch tun?



Backup zurückspielen und nochmal nach Anleitung. Dann klappt es.

http://www.debian.org/releases/stab...ng.de.html

Deine Fehlermeldung steht unter 4.5.1.


Marcel

Ähnliche fragen