Divisionsproblem in Excel

03/01/2008 - 09:23 von Marcel Debrus | Report spam
Liebe NG,

es besteht folgendes Problem: In einer Excel-Tabelle sollen Zahlen aus
bspw 5 Spalten zeilenweise addiert und dann durch die Anzahl der zu
addiernden Spalten dividiert werden (also 5). Jetzt tritt der Fall ein,
das nicht immer jede Spalte besetzt ist und entsprechend anders
dividiert werden muss.
Zur Veranschaulichung ein konkretes Beispiel: (A,B.. =Spalten, 1,2,...=
Reihen)

A B C D (zuproduzierendes Ergebnis:)
1 5 2 3 1 (=(5+2+3+1)/4)
2 3 3 (=(3+3)/2)

Wie "bringe" ich Excel jetzt bei, dass er auf Grund der "Lücken" in B2
und D2 nur durch 2 dividieren soll?

Danke für eure Hilfe

PS. Habt ihr für solche und àhnliche Probleme einen guten
(Offline-)Buchtipp?

Marcel
 

Lesen sie die antworten

#1 Lorenz Hölscher
03/01/2008 - 09:34 | Warnen spam
Hallo Marcel,

was hàlst Du von =SUMME(A1:C1)/ANZAHL(A1:C1)?

Du kannst das prüfen, indem Du in der Eingabezeile ANZAHL(...)
markierst und <F9> drückst, dann wird dieser Teil einzeln gerechnet.
Aber Achtung, mit <Esc> verlassen, sonst ist die Formel durch das
Ergebnis ersetzt!

tschö, Lorenz

http://www.cls-software.de/cls_soft...rmeln.aspx

Ähnliche fragen