DLL- "Fehler bei Zugriff auf die Systemregistrierung"

11/12/2009 - 13:13 von Heinz-Mario Frühbeis | Report spam
Hallo!

Meine Sofware :
VISTA 32
VB6 (ohne SP (da ich keines der SP's installiert bekomme; (noch nicht mal
SP3) )

Ich habe eine DLL geschrieben.
Diese DLL beinhaltet einige Properties --> String- und Long-Werte.
Möchte ich diese DLL dann erstellen, klappt das auch soweit
(heißt: die Datei wird erstellt) allerdings kommt dann eine Meldung :

"Fehler bei Zugriff auf die Systemregistrierung"

In einer anderen Anwendung kann ich diese DLL dann auch als Verweis
eintragen.
Allerdings kann ich diese dann nicht im Code unterbringen.
Dim x as Test.TestCl
set x = new Test.TestCl (--> ActiveX-Objecterstellung nicht möglich)

Ich hatte vor VISTA lange, lange W2k als BS. Da hatte ich nie dererlei
Probleme.
Liegt das an VISTA?

Wie kann ich denn nun eine DLL schreiben und sie ordungsgemàß registrieren,
das ich diese als Verweis verwenden kann?

Hoffe das mir jemand helfen kann
Heinz-Mario
 

Lesen sie die antworten

#1 Heinz-Mario Frühbeis
11/12/2009 - 13:35 | Warnen spam
Hi!

Ich glaube (hoffe) das sich das Problem erledigt hat.
Ich habe VB6.exe "als Administrator" ausgeführt und dann im Dialog das
DLL-Projekt manuell ausgewàhlt.
Damit klappt das alles jetzt so, wie es sein soll.

Nichts für ungut
Heinz-Mario

"Heinz-Mario Frühbeis" schrieb im Newsbeitrag
news:
Hallo!

Meine Sofware :
VISTA 32
VB6 (ohne SP (da ich keines der SP's installiert bekomme; (noch nicht mal
SP3) )

Ich habe eine DLL geschrieben.
Diese DLL beinhaltet einige Properties --> String- und Long-Werte.
Möchte ich diese DLL dann erstellen, klappt das auch soweit
(heißt: die Datei wird erstellt) allerdings kommt dann eine Meldung :

"Fehler bei Zugriff auf die Systemregistrierung"

In einer anderen Anwendung kann ich diese DLL dann auch als Verweis
eintragen.
Allerdings kann ich diese dann nicht im Code unterbringen.
Dim x as Test.TestCl
set x = new Test.TestCl (--> ActiveX-Objecterstellung nicht möglich)

Ich hatte vor VISTA lange, lange W2k als BS. Da hatte ich nie dererlei
Probleme.
Liegt das an VISTA?

Wie kann ich denn nun eine DLL schreiben und sie ordungsgemàß
registrieren,
das ich diese als Verweis verwenden kann?

Hoffe das mir jemand helfen kann
Heinz-Mario

Ähnliche fragen