DNS Problem unter XP (nslookup geht, ping nicht für LAN Hosts)

06/04/2008 - 14:14 von Oliver Pfeiffer | Report spam
Hallo,

ich habe hier ein wirklich nerviges Problem mit unseren XP Systemen. Wir
nutzen einen Router mit DHCP und lokalem DNS, der uns über PPPoE/NAT ins
Internet bringt. Der Router kennt alle Rechner im lokalen Netz und der
installierte DNS Server löst diese auch scheinbar korrekt auf.

Dummerweise lösen die XP Rechner sàmtliche lokalen Hostnamen im LAN nicht
auf, die nicht über NETBIOS via Broadcast ermittelt werden können (also
z.B. Linux Printserver o.à.). Alle übrigen entfernten Hostnamen im WAN
funktionieren problemlos (heise.de, etc.)

Falls da jemand einen Tipp hat, dann würde ich mich riesig freuen, weil
dieses Problem wirklich die Nerven strapaziert! :((


Hier die Auflösung des Routers von einer XP Workstation:

C:\>nslookup router
Server: router
Address: 192.168.10.1
Name: router
Address: 192.168.10.1
C:\>ping router
Ping-Anforderung konnte Host "router" nicht finden.


Hier die Auflösung eines Linux Printserver von einer XP Workstation:

C:\>nslookup printserver
Server: router
Address: 192.168.10.1
Name: printserver
Address: 192.168.10.105
C:\>ping printserver
Ping-Anforderung konnte Host "printserver" nicht finden.


Hier die Auflösung eines Samba Servers von einer XP Workstation:

C:\>nslookup samba
Server: router
Address: 192.168.10.1
Name: samba
Address: 192.168.10.106
C:\>ping samba
Ping samba [192.168.10.106] mit 32 Bytes Daten:
Antwort von 192.168.10.106: Bytes2 Zeit<1ms TTLd


Hier die Netzwerkkonfiguration der XP Workstation:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Marvell Yukon 88E8052 PCI-E ASF Gigabit
Ethernet Controller
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IP-Adresse. . . . . . . . . . . . : 192.168.10.100
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.10.1
DHCP-Server . . . . . . . . . . . : 192.168.10.1
DNS-Server. . . . . . . . . . . . : 192.168.10.1
Lease erhalten. . . . . . . . . . : Sonntag, 6. April 2008 12:07:30
Lease làuft ab. . . . . . . . . . : Dienstag, 19. Januar 2038 05:14:07

Grüße - Regards
Oliver Pfeiffer
ICQ-ID 84320006
 

Lesen sie die antworten

#1 Ralf Breuer
06/04/2008 - 15:13 | Warnen spam
Oliver Pfeiffer schrieb:

Hallo Oliver,

Dummerweise lösen die XP Rechner sàmtliche lokalen Hostnamen im LAN
nicht auf, die nicht über NETBIOS via Broadcast ermittelt werden
können (also z.B. Linux Printserver o.à.).

Hier die Auflösung des Routers von einer XP Workstation:

C:\>nslookup router
Server: router
Address: 192.168.10.1
Name: router
Address: 192.168.10.1
C:\>ping router
Ping-Anforderung konnte Host "router" nicht finden.



Ein Eintrag in \windows\system32\drivers\etc\hosts wird helfen.

Hier die Auflösung eines Linux Printserver von einer XP Workstation:

C:\>nslookup printserver
Server: router
Address: 192.168.10.1
Name: printserver
Address: 192.168.10.105
C:\>ping printserver
Ping-Anforderung konnte Host "printserver" nicht finden.



Der printserver spricht nicht Samba?

Hier die Netzwerkkonfiguration der XP Workstation:



Zum Knotentyp steht da was?

Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Ähnliche fragen