doppelte Buchstaben nach update auf opensuse 11.2

08/12/2009 - 03:03 von Bettina Grohnert | Report spam
In allen KDE Anwendungen einschließlich Login habe ich seit dem Update
von opensuse 11.1 auf 11.2 den Effekt, dass alle Buchstaben und
Sonderzeichen doppelt angezeigt werden. Merkwürdig ist: wenn ich
CapsLock anschalte, kommt Aa statt a, bei gedrückter Shifttaste AA. Bei
angeschaltetem NumLock werden die Ziffern korrekt also einzeln
ausgegeben, bei abgeschaltetem Numlock gar nicht. Hat jemand eine
Erklàrung? Hier die Auszüge aus der /etc/X11/XF86config:

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection

/var/log/Xorg.0.log:

(**) Option "CoreKeyboard"
(**) Keyboard[0]: always reports core events
(**) Option "Protocol" "Standard"
(**) Keyboard[0]: Protocol: Standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) Keyboard[0]: XkbRules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) Keyboard[0]: XkbModel: "pc105"
(**) Option "XkbLayout" "de"
(**) Keyboard[0]: XkbLayout: "de"
(**) Option "XkbVariant" "nodeadkeys"
(**) Keyboard[0]: XkbVariant: "nodeadkeys"
(**) Option "CustomKeycodes" "off"
(**) Keyboard[0]: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard[0]" (type: KEYBOARD)
(II) XKB: generating xkmfile
/tmp/server-393AE7579A203F2226DA6F7CA598130F15E358A6.xkm
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules//input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 2.2.5
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard"
(type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "de"
(**) Option "xkb_variant" "nodeadkeys"
(II) XKB: generating xkmfile
/tmp/server-84CA2CD290FA78358D33127D25A86D7EAC12A9E5.xkm


X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux 2.6.31.5-0.1-default #1 SMP
2009-10-26 15:49:03 +0100 i686
Build Date: 02 November 2009 12:05:39PMX.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux 2.6.31.5-0.1-default #1 SMP
2009-10-26 15:49:03 +0100 i686
Build Date: 02 November 2009 12:05:39PM



Im KDE ist die Tastenwiederholung ausgeschaltet.



Ohne X11, also auf der Textkonsole ist alles einwandfrei.

Hoffe auf schnelle Hilfe,
Betti
 

Lesen sie die antworten

#1 Reinhard Tchorz
08/12/2009 - 10:24 | Warnen spam
Hi,

In allen KDE Anwendungen einschließlich Login habe ich seit dem Update
von opensuse 11.1 auf 11.2 den Effekt, dass alle Buchstaben und
Sonderzeichen doppelt angezeigt werden. Merkwürdig ist: wenn ich
CapsLock anschalte, kommt Aa statt a, bei gedrückter Shifttaste AA. Bei
angeschaltetem NumLock werden die Ziffern korrekt also einzeln
ausgegeben, bei abgeschaltetem Numlock gar nicht. Hat jemand eine
Erklàrung? Hier die Auszüge aus der /etc/X11/XF86config:



Schnipp

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux 2.6.31.5-0.1-default #1 SMP
2009-10-26 15:49:03 +0100 i686
Build Date: 02 November 2009 12:05:39PMX.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux 2.6.31.5-0.1-default #1 SMP
2009-10-26 15:49:03 +0100 i686
Build Date: 02 November 2009 12:05:39PM



Seit X-Server 1.5 übernimmt HAL die Konfiguration der Hardware.
Die Angaben in der xorg.conf sind deshalb eigentlich nicht mehr nötig.
Das alte Verhalten kann jedoch dadurch wiederhergestellt werden, in dem
die folgenden Eintràge in xorg.conf eingefügt werden:

Section "ServerFlags"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"
EndSection


Gruß
Reinhard

Gentoo Kernel 2.6.30 X-Server 1.6.3 KDE 4.3.3
Asus M2A-VM AMD Athlon X2 4450e Nvidia 7300LE

Ähnliche fragen