Drucken von DOS-Anwendung unter Vista 32-bit

08/11/2008 - 02:08 von GP | Report spam
Hallo,

folgendes Problem:

Ich versuche, einer DOS-Anwendung auf einem Vista-32-Home-Premium-Laptop das
Drucken beizubringen. Die Anwendung druckt auf einen frei wàhlbaren
Standard-LPT-port (LPT1:, LPT2: ..) Da der Laptop keine
Parallelschnittstelle hat, hat er ein USB->Parallel-Kabel (mit integriertem
Controller) bekommen.

Auf jedem XP-Laptop mit einer Netzverbindung funktioniert folgende Prozedur
einwandfrei:

Kabel anhàngen, USB zu IEE-1284-Treiber wird automatisch geladen.
Drucker einschalten und Windows-Treiber installieren
Den Drucker freigeben, zB als LQ300
In der console eingeben: NET USE LPT1: \\Computername\LQ300 /persistent:yes
Mit NET USE kontrollieren, ob der LPT1: wirklich verbunden ist
Mit DIR > LPT1: testen, ob wirklich gedruckt wird.
Jetzt druckt auch die Anwendung auf dem Drucker an LPT1: - keine Probleme.

Bei Vista funktioniert das alles ebenso, es wird auch zB mit DIR > LPT1: von
der console her einwandfrei gedruckt !

Nur: Die Anwendung druckt nicht, sondern sagt: 'Geràt nicht bereit' und
verabschiedet sich. Mit 'Geràt' ist natürlich der Drucker gemeint.

Bei der Suche im web stoße ich auf einige identische Problemberichte, sehe
aber nirgends eine Lösung.

Verschiedentlich wird die Meinung vertreten, dass es da im Vista eben ein
ungelöstes Problem gàbe.

Der Hinweis, dass das bekannte PRINTFIL die einwandfreie Lösung zum Problem
wàre, ist zwar lieb, ich sehe aber eigentlich nicht ein, warum wir noch
zusàtzlich zu jedem Vista-Laptop die Extra-Abgabe von 44,- Euro leisten
sollen, bloß, weil Vista nicht tut, was es eigentlich sollte bzw was auch
der Vorgànger XP problemlos beherrschte.

Vielleicht kennt jemand den Dreh, den Drucker unter Vista doch zum
Funktionieren zu bekommen?

Vielen Dank im Voraus
Günter Predl
 

Lesen sie die antworten

#1 GP
08/11/2008 - 09:44 | Warnen spam
Hier wird übrigens das exakt gleiche Problem beschrieben:
http://www.vistax64.com/vista-print...ogram.html
Mfg Günter


"GP" schrieb im Newsbeitrag
news:%
Hallo,

folgendes Problem:

Ich versuche, einer DOS-Anwendung auf einem Vista-32-Home-Premium-Laptop
das Drucken beizubringen. Die Anwendung druckt auf einen frei wàhlbaren
Standard-LPT-port (LPT1:, LPT2: ..) Da der Laptop keine
Parallelschnittstelle hat, hat er ein USB->Parallel-Kabel (mit
integriertem Controller) bekommen.

Auf jedem XP-Laptop mit einer Netzverbindung funktioniert folgende
Prozedur einwandfrei:

Kabel anhàngen, USB zu IEE-1284-Treiber wird automatisch geladen.
Drucker einschalten und Windows-Treiber installieren
Den Drucker freigeben, zB als LQ300
In der console eingeben: NET USE LPT1: \\Computername\LQ300
/persistent:yes
Mit NET USE kontrollieren, ob der LPT1: wirklich verbunden ist
Mit DIR > LPT1: testen, ob wirklich gedruckt wird.
Jetzt druckt auch die Anwendung auf dem Drucker an LPT1: - keine Probleme.

Bei Vista funktioniert das alles ebenso, es wird auch zB mit DIR > LPT1:
von der console her einwandfrei gedruckt !

Nur: Die Anwendung druckt nicht, sondern sagt: 'Geràt nicht bereit' und
verabschiedet sich. Mit 'Geràt' ist natürlich der Drucker gemeint.

Bei der Suche im web stoße ich auf einige identische Problemberichte, sehe
aber nirgends eine Lösung.

Verschiedentlich wird die Meinung vertreten, dass es da im Vista eben ein
ungelöstes Problem gàbe.

Der Hinweis, dass das bekannte PRINTFIL die einwandfreie Lösung zum
Problem wàre, ist zwar lieb, ich sehe aber eigentlich nicht ein, warum wir
noch zusàtzlich zu jedem Vista-Laptop die Extra-Abgabe von 44,- Euro
leisten sollen, bloß, weil Vista nicht tut, was es eigentlich sollte bzw
was auch der Vorgànger XP problemlos beherrschte.

Vielleicht kennt jemand den Dreh, den Drucker unter Vista doch zum
Funktionieren zu bekommen?

Vielen Dank im Voraus
Günter Predl





Ähnliche fragen