Forums Neueste Beiträge
 

Drucker an Linux-Rechner (Cups) ist im Netz von Vista-Rechner nicht erreichbar

06/07/2008 - 13:17 von Volker Lenhardt | Report spam
Ich habe in einem Heimnetz einen Linux-Desktop (Suse 10.3) mit zwei
lokalen Druckern, einem USB-Tintenstrahler und bis vor kurzem einem
Parallel-Laser. Sowohl von einem XP-Laptop wie auch von einem
Vista-Laptop konnte ich auf beide über Internet Port
http://meinlinuxrechner:631/printers/druckername drucken. In der
Druckersteuerung erscheinen die Drucker unter dem Namen "druckername an
http://meinlinuxrecher:631/printers/druckername".

Nun habe ich den Parallel-Drucker durch einen USB-Laser (Kyocera
FS-1300D) ersetzt. Die Einrichtung auf dem XP-Laptop funktionierte
problemlos: kein Unterschied zu vorher.

Doch auf dem Vista-Laptop ist nur der Tintenstrahler unveràndert
einsatzbereit. Es gelingt mir nicht, den Laserdrucker genauso zu
verwenden. Auf "Standard TCP/IP Port" wird der Drucker gar nicht
gefunden. Also habe ich einen neuen Port angelegt:
"http://meinlinuxrecher:631/printers/druckername". Der Druckername wurde
aber nicht automatisch übernommen, ich musste manuell einen eingeben.
Der Drucker wird erkannt und druckt, wird aber unter dem manuell
vergebenen Namen aufgeführt (nicht "druckername an http...") .

Allerdings ist er nach einem Vista-Neustart nur noch als Offline
gelistet. Kein Druck mehr möglich. Der Tintenstrahler funktioniert
weiterhin.

Ich kann mich nicht erinnern, ob ich vor vier Monaten (mit der
vorherigen Konstellation) einen anderen Weg der Druckereinrichtung
beschritten habe. Hat irgendein Vista-Update etwas veràndert?

Ich habe in Google in dem Wust von Vista-Netzwerk-und-Drucker-Problemen
keine Antwort auf meine Situation gefunden. Vielleicht habe ich den Wald
vor lauter Bàumen nicht gesehen.

Gruß
Volker
 

Lesen sie die antworten

#1 Norbert Hahn
06/07/2008 - 15:57 | Warnen spam
On Sun, 06 Jul 2008 13:17:09 +0200, Volker Lenhardt wrote:

Ich habe in einem Heimnetz einen Linux-Desktop (Suse 10.3) mit zwei
lokalen Druckern, einem USB-Tintenstrahler und bis vor kurzem einem
Parallel-Laser. Sowohl von einem XP-Laptop wie auch von einem
Vista-Laptop konnte ich auf beide über Internet Port
http://meinlinuxrechner:631/printers/druckername drucken. In der
Druckersteuerung erscheinen die Drucker unter dem Namen "druckername an
http://meinlinuxrecher:631/printers/druckername".



Das ist so in Ordnung.

Nun habe ich den Parallel-Drucker durch einen USB-Laser (Kyocera
FS-1300D) ersetzt. Die Einrichtung auf dem XP-Laptop funktionierte
problemlos: kein Unterschied zu vorher.

Doch auf dem Vista-Laptop ist nur der Tintenstrahler unveràndert
einsatzbereit. Es gelingt mir nicht, den Laserdrucker genauso zu
verwenden. Auf "Standard TCP/IP Port" wird der Drucker gar nicht
gefunden.



Kann er auch nicht, weil weder irgendein Rechner noch der Drucker den
Port 9100 offen hat (hoffentlich!).

Also habe ich einen neuen Port angelegt:
"http://meinlinuxrecher:631/printers/druckername". Der Druckername wurde



Das was in "http://meinlinuxrecher:631/printers/druckername" steht
bedeutet, dass das Internet Printing Protocol benutzt wird, dessen
Realisierung in der Unix- und MacOS X-Welt CUPS heißt.
Das ist _kein_ Port, den man irgendwie auf einem anderen Rechner
einfach so einrichten könnte.

aber nicht automatisch übernommen, ich musste manuell einen eingeben.
Der Drucker wird erkannt und druckt, wird aber unter dem manuell
vergebenen Namen aufgeführt (nicht "druckername an http...") .



Ich weiß nicht, was da schief gelaufen ist, wenn da ein Drucker "erkannt"
wird.

Ich habe in Google in dem Wust von Vista-Netzwerk-und-Drucker-Problemen
keine Antwort auf meine Situation gefunden. Vielleicht habe ich den Wald
vor lauter Bàumen nicht gesehen.



Vielleicht suchst Du mal Vista und Internet Printing Protocol einrichten.
Jedenfalls hat Vista als Betriebssystem kein Problem, dieses Protokoll zu
benutzen.

Norbert

Ähnliche fragen