Drucker im Netzwerk: Problem

26/06/2009 - 12:10 von Andreas Koerber | Report spam
Hallo,
ich habe zu Hause ein kabelgebundenes LAN, das WAN-seitig an einem
Kabelanschluss hàngt). Router ist ein BELKIN. Die WLAN-Funktion ist
abgeschaltet. Ein WLAN ist über einen eigenen BELKIN-Router an diesem
realisiert, damit es hardwaremàßig (über einen Stromschalter) ein- und
ausgeschaltet werden kann.

Außer dem zweiten BELKIN für WLAN hàngen die Rechner alle per SWITCH
verteilt direkt am ersten BELKIN. Das funktioniert gut.

NEBEN diesen ganzen Rechnern habe ich einen weiteren Router (SAMSUNG)
hàngen, der einen USB-Printerserver enthàlt. daran ist Drucker (HP 1100)
per USB angeschlossen.

In einer früheren Konfiguration, in der einige Rechner unterhalb dieses
SAMSUNG in einem eigenen Teilnetz hingen, konnte ich den Drucker aus dem
ganzen Netzwerk ansprechen, also auch von "oberhalb" des SAMSUNG, von
Rechnern, die direkt am BELKIN hingen.

Nun, wo alle Rechner direkt am BELKIN sind, erreiche ich den Drucker gar
nicht mehr.

Die Konfiguration des SAMSUNG sagt, der Printserver sei in Betrieb und
zeigt auch den Drucker an.
Der SAMSUNG Router hat "intern" in seinem eigenen Teilnetz die Adresse
192.168.220.1, im oberen Netzwerk hat er (per fester Zuweisung)
192.168.200.4.

Die übrigen Rechner erhalten ihre Adressen vom BELKIN (192.100.200.1)
per DHCP im Raum 192.168.200.5 - .99.

Ich habe keine Ahnung, wieso ich den Drucker nicht mehr ansprechen kann.
Ich habe versucht, ihn über einen IP_STANDARD-Anschluss 192.168.200.4
anzusprechen, aber das geht nicht, weil ich keine Freigabe machen kann -
er ist ja nicht an einem Computer angeschlossen.

Hat jemand eine Vorstellung, wie ich den Drucker installieren muss,
damit er wirklich im ganzen Netzwerk erkannt wird?

Dank im Voraus

A.Körber

PS: Rechner:alle XP Pro, einer VISTA Home Premium
 

Lesen sie die antworten

#1 Andre Tann
27/06/2009 - 17:42 | Warnen spam
Andreas Koerber wrote:

Die Konfiguration des SAMSUNG sagt, der Printserver sei in Betrieb und
zeigt auch den Drucker an.
Der SAMSUNG Router hat "intern" in seinem eigenen Teilnetz die Adresse
192.168.220.1, im oberen Netzwerk hat er (per fester Zuweisung)
192.168.200.4.
Die übrigen Rechner erhalten ihre Adressen vom BELKIN (192.100.200.1)
per DHCP im Raum 192.168.200.5 - .99.



Da dürfte der Hund begraben sein. Warum hast Du denn zwei verschiedene
Netzwerksegmente eingerichtet?

Schau Dir doch mal die Routing-Tabellen der Rechner im .200.er Netz an.
Die werden wahrscheinlich alles, was nicht .200. ist, aufs
Standard-Gateway werfen, also auf den Belkin. Sprich: Pakete der PCs an
Dein Netz hinter dem Samsung, also an das .220.er Netz, landen beim
Belkin. Dieser müßte also wissen, wohin er mit diesen Paketen soll,
nàmlich nicht auf sein eigenes Standard-Gateway (also wohl beim
Provider), sondern auf den Samsung, sprich: auf die .200.4, die
wiederum nach unten durchrouten müßte auf 220.1.

Und auch der umgekehrte Weg müßte funktionieren. Weiß die 220.1, wohin
sie mit Paketen an .220. soll? Wenn auf das Standard-Gateway (welches
auch immer das ist) - weiß das Standard-Gateway, daß diese Pakete nicht
zum Provider, sondern in Dein anderes Netzwerksegment sollen?

Du schreibst nichts über Deine Netzwerkmaske. Wenn das wie üblich /24
ist, dann stimmt das, was ich oben geschrieben habe. Wenn es
ungewöhnlicherweise /16 wàre oder sonst was anderes, dann müßte man das
nochmal genauer ansehen.

Aber wie gesagt - ich sehe nicht, wieso Du überhaupt zwei Segmente
willst, wenn Du Dir damit den Rattenschwanz des Routings einhandelst.
Der einzige Grund, der mir so einfàllt, wàre ein verteiltes (V)LAN mit
VPNs dazwischen. Ist das bei Dir so?




Andre Tann

Ähnliche fragen