Drucker/Spoolerproblem

02/07/2009 - 12:33 von Stefan Dreyer | Report spam
Hallo,

ich habe ein sehr merkwürdiges Problem. In einer Domàne sind zwei
Arbeitsplàtze (Vista Business) eingebunden. Diese benutzen eine
Internetapplikation, die per Batchprogramm Dateien direkt an einen
freigegebenen Drucker schickt. Die Batchdatei sieht folgendermaßen aus:
copy /b %1 //arbeitsplatz/drucker

Bisher hat das auch tadellos funktioniert. Die Arbeitsplàtze sind jetzt
aber umgezogen und an einen anderen Standort gezogen und per VPN an die
Domàne angebunden. Seit dem besteht das Problem, dass bei jedem Druck
willkürlich alte Dateien noch mal an den Drucker geschickt werden, wenn
ich einen neuen Druckauftag versende. Da befinden sich dann statt einem
gleich mehrere Druckauftràge in der Warteschlange.

Ich habe jetzt mal auf dem Arbeitsplatz, an dem der Drucker hàngt, die
Batchdatei geàndert und kopiere direkt auf die Parallele Schnittstelle.
(copy /b %1 lpt1). Damit funktioniert alles. Aber warum werden bei der
anderen Version alte Auftràge erneut gedruckt? Kann das am Spooler liegen?
 

Lesen sie die antworten

#1 Ralf Breuer
02/07/2009 - 12:54 | Warnen spam
Stefan Dreyer schrieb:

Hallo Stefan,

ich habe ein sehr merkwürdiges Problem. In einer Domàne sind zwei
Arbeitsplàtze (Vista Business) eingebunden. Diese benutzen eine
Internetapplikation, die per Batchprogramm Dateien direkt an einen
freigegebenen Drucker schickt. Die Batchdatei sieht folgendermaßen
aus: copy /b %1 //arbeitsplatz/drucker

Bisher hat das auch tadellos funktioniert. Die Arbeitsplàtze sind
jetzt aber umgezogen und an einen anderen Standort gezogen und per
VPN an die Domàne angebunden. Seit dem besteht das Problem, dass bei
jedem Druck willkürlich alte Dateien noch mal an den Drucker
geschickt werden, wenn ich einen neuen Druckauftag versende. Da
befinden sich dann statt einem gleich mehrere Druckauftràge in der
Warteschlange.
Ich habe jetzt mal auf dem Arbeitsplatz, an dem der Drucker hàngt, die
Batchdatei geàndert und kopiere direkt auf die Parallele
Schnittstelle. (copy /b %1 lpt1). Damit funktioniert alles. Aber
warum werden bei der anderen Version alte Auftràge erneut gedruckt?
Kann das am Spooler liegen?



Leere mal auf dem Druckerserver den Ordner
\WINDOWS\system32\spool\PRINTERS

Wenn das nicht hilft:
In den Eigenschaften des Druckers, Anschlüsse, Bidirektionales Drucken
deaktivieren.

Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Ähnliche fragen