DTMF-Decoder NE567

01/07/2014 - 18:51 von Johannes Bauer | Report spam
Hallo Gruppe,

ich habe ein Problem. Würde mir gerne DTMF decodieren und dazu einen
KA567 verwenden. Habe ihn in folgender Schaltung an Vcc = 5V mit einem
Signal etwa 200mVpp (habe zwischen 100mVpp und 400mVpp herumprobiert,
immer selbes Ergebnis):

100nF
+--||--+
| |
Vcc --+--||--+ GND
10uF


Vcc
|
10k
|
100nF KA567 |
IN o||--[ 3 In Out 8]--+-
[ ]
1uF [ ] 22nF
GND||--[ 2 LFIL OFIL 1]-||- GND
[ ]
+-[ 5 RT V+ 4 ] Vcc
| [ ]
100 [ ]
| [ ]
+-[ 6 CT GND 7] GND
|
10.7u == |
GND


Mein Signal kommt von einem Elektretmikrofon und wird dann auf etwa
100mVpp bis 400mVpp einstellbar verstàrkt. Egal bei welchem Pegel ist
das Fehlerbild aber immer das gleiche: Das Ding detektiert so ziemlich
alles, außer das Signal, dass es detektieren soll. Wenn ich da also
reinhuste oder pfeife dann geht das Ausgang an (also auf LOW), aber wenn
ein wirklich sauberes DTMF-Signal reinkommt dann passiert nix. Ich würde
gerne 852 Hz detektieren.

R an RT sind echte 100 Ohm (+- 0.1%) und den C habe ich auf 10.7uF
selektiert und ausgemessen. Sind laut Datenblatt also 849 Hz, da f = 1 /
(1.1 RC).

Da ich mit dem KA567 keine Erfahrung habe frage ich mal in die Runde, ob
einem auffàllt was ich falsch machen könnte. Bin für alle Tipps dankbar.

Viele Grüße,
Johannes




Wo hattest Du das Beben nochmal GENAU vorhergesagt?


Zumindest nicht öffentlich!


Ah, der neueste und bis heute genialste Streich unsere großen
Kosmologen: Die Geheim-Vorhersage.
- Karl Kaos über Rüdiger Thomas in dsa <hidbv3$om2$1@speranza.aioe.org>
 

Lesen sie die antworten

#1 Joerg
01/07/2014 - 19:08 | Warnen spam
Johannes Bauer wrote:
Hallo Gruppe,

ich habe ein Problem. Würde mir gerne DTMF decodieren und dazu einen
KA567 verwenden. Habe ihn in folgender Schaltung an Vcc = 5V mit einem
Signal etwa 200mVpp (habe zwischen 100mVpp und 400mVpp herumprobiert,
immer selbes Ergebnis):

100nF
+--||--+
| |
Vcc --+--||--+ GND
10uF


Vcc
|
10k
|
100nF KA567 |
IN o||--[ 3 In Out 8]--+-
[ ]
1uF [ ] 22nF
GND||--[ 2 LFIL OFIL 1]-||- GND
[ ]
+-[ 5 RT V+ 4 ] Vcc
| [ ]
100 [ ]
| [ ]
+-[ 6 CT GND 7] GND
|
10.7u ==> |
GND


Mein Signal kommt von einem Elektretmikrofon und wird dann auf etwa
100mVpp bis 400mVpp einstellbar verstàrkt. Egal bei welchem Pegel ist
das Fehlerbild aber immer das gleiche: Das Ding detektiert so ziemlich
alles, außer das Signal, dass es detektieren soll. Wenn ich da also
reinhuste oder pfeife dann geht das Ausgang an (also auf LOW), aber wenn
ein wirklich sauberes DTMF-Signal reinkommt dann passiert nix. Ich würde
gerne 852 Hz detektieren.

R an RT sind echte 100 Ohm (+- 0.1%) und den C habe ich auf 10.7uF
selektiert und ausgemessen. Sind laut Datenblatt also 849 Hz, da f = 1 /
(1.1 RC).

Da ich mit dem KA567 keine Erfahrung habe frage ich mal in die Runde, ob
einem auffàllt was ich falsch machen könnte. Bin für alle Tipps dankbar.




Die Bauteilwerte sind arg schief. Z.B. sollte der Timing Widerstand im
kohm Bereich liegen und dafuer der Timing Cap kleiner. Beispiel:

http://wiringdiagramcircuit.com/inf...567-lm308/

Auch der Loop Filter Kondensator ist normalerweise um mehrere
Groessenordnungen kleiner, aber das haengt von der Anwendung ab
(Ansprechzeit, Bandbreite). Output Filter hingegen ist normalerweise
groesser.

Gruesse, Joerg

http://www.analogconsultants.com/

Ähnliche fragen