durch spalten iterieren

02/08/2009 - 14:03 von klaus.könig | Report spam
hallo zusammen

folg. code prüft ab der zeile 15 bzw. zelle b15 in der spalte b bis
zur leeren zelle ab und tràgt bei wahr eine formel in spalte e ein.

nun möchte ich, dass in den spalten g bis f jeweils andere formeln bei
gleicher do/loop-schleife eingetragen werden. welche schleife muss mit
der do/loop-schleife geschachtelt werden?

ersteZeile = 15
Do While Not IsEmpty(Cells(ersteZeile, 2))
Cells(ersteZeile, 5).FormulaLocal = "=SVERWEIS(B" &
ersteZeile & ";xTab_Massnahmen!$A$3:$L$22;6;FALSCH)"
ersteZeile = ersteZeile + 1
Loop
End Sub

freue mich auf eine antwort
 

Lesen sie die antworten

#1 Andreas Killer
02/08/2009 - 14:16 | Warnen spam
klaus.könig schrieb:

nun möchte ich, dass in den spalten g bis f jeweils andere formeln bei
gleicher do/loop-schleife eingetragen werden.


Naja, dann mach das doch ala "Cells(ersteZeile, 6).FormulaLocal ="

welche schleife muss mit der do/loop-schleife geschachtelt werden?


Was bitte? Keine! Frag einfach die Zelle ab:

"if IsEmpyt(Cells(ersteZeile, 6)) then"

Andreas.

Ähnliche fragen