dynamische Matrixformel SUMMENPRODUKT

05/06/2008 - 13:11 von Andreas Tchorsch | Report spam
Hallo zusammen,

mit der Matrix-Formel
{=SUMMENPRODUKT(($D$2:$D$471<²)*($E$2:$E$471>B2);$A$2:$A$471)} berechne ich
eine Summe (Werte in Spalte A) in Abhàngigkeit eines Datums (Spalte B).
Die Lànge der Liste kann variieren. Wie kann ich das Ende (hier fix: Zeile
471) dynamisch in Abhàngigkeit der Zeile 472 gestalten ?

Vielen Dank.

Andreas
 

Lesen sie die antworten

#1 thomas.ramel
05/06/2008 - 15:13 | Warnen spam
Grüezi Andreas

On 5 Jun., 13:11, Andreas Tchorsch
wrote:

mit der Matrix-Formel
{=SUMMENPRODUKT(($D$2:$D$471<²)*($E$2:$E$471>B2);$A$2:$A$471)}



Warum hast Du hier die {}-Klammern um die Formel - bei SUMMENPRODUKT()
ist das nicht notwendig (einer der IMO grossen Vorteile dieser
Formel).

berechne ich
eine Summe (Werte in Spalte A) in Abhàngigkeit eines Datums (Spalte B).
Die Lànge der Liste kann variieren. Wie kann ich das Ende (hier fix: Zeile
471) dynamisch in Abhàngigkeit der Zeile 472 gestalten ?



Erstelle einen dynamischen Bereichsnamen, dessen Grösse sich nach den
vorhandenen Daten richtet und verwende dann diesen Namen anstelle des
direkten Bezuges.

Hinweise zum Erstellen dieses Namens findest Du mit Googele hier in
der NG bestimmt viele.

Mit freundlichen Grüssen

Thomas Ramel
- MVP für MS-Excel -

Ähnliche fragen