E-Mail-Adresse wird falsch konstruiert

21/12/2007 - 14:36 von helmut | Report spam
Hallo alle miteinander,

wo ist das folgende Problem am ehesten zu klàren:

when I try to send e-mail to a local user (p.e. root) who has no entry
in my adress book and I write only "root" into the "To:" field
squirrelmail refuses work with

Wenn ich mit "squirrelmail" Post an einen existenten lokalen user
verschicken will, z.B. an "root", und im "To: "-Feld nur "root" eingebe,
mault "squirrelmail"

FEHLER
Message not sent.
Geforderte Aktion nicht ausgeführt: Postfachname nicht zulàssig
Server antwortete: 553 5.0.0 <root@wm8.hullen.de... Unbalanced '<'

An: root




Da wird also das schliessende ">" nicht mitgeliefert.
Wenn ich als Adresse "root@localhost" eingebe, wird die Adresse
akzeptiert und verarbeitet.

Wenn ich den gleichen Versuch mit "IlohaMail" starte, dann akzeptiert
"IlohaMail" schon vorher die Adresse (ohne Domain-Anhàngsel) nicht - ok.

Einige Benutzer von "Squirrelmail" versichern standhaft, dass bei ihren
Installationen dieser Fehler nicht auftritt, und es könnte sein, dass er
auch bei meinen Installationen erst seit einiger Zeit auftritt - ist mir
früher nicht aufgefallen (was nicht viel heisst).

Welche Station auf dem langen Weg hat aus "root" (o.à.) den langen Teil
"<root@domain.org>" zu machen? Das Webmail-Programm oder irgendein
nachgeschaltetes Programm?

Falls es wichtig ist:

echo pong | mail -s ping root

funktioniert brav.

Viele Gruesse
Helmut

"Ubuntu" - an African word, meaning "Slackware is too hard for me".
 

Lesen sie die antworten

#1 Christian Winter
23/12/2007 - 09:59 | Warnen spam
Helmut Hullen schrieb:
Hallo alle miteinander,

wo ist das folgende Problem am ehesten zu klàren:

when I try to send e-mail to a local user (p.e. root) who has no entry
in my adress book and I write only "root" into the "To:" field
squirrelmail refuses work with

Wenn ich mit "squirrelmail" Post an einen existenten lokalen user
verschicken will, z.B. an "root", und im "To: "-Feld nur "root" eingebe,
mault "squirrelmail"

FEHLER
Message not sent.
Geforderte Aktion nicht ausgeführt: Postfachname nicht zulàssig
Server antwortete: 553 5.0.0 Unbalanced '<'

An: root




Da wird also das schliessende ">" nicht mitgeliefert.
Wenn ich als Adresse "" eingebe, wird die Adresse
akzeptiert und verarbeitet.



Die Fehlermeldung oben zeigt, dass die Mail direkt via SMTP
eingeliefert wird, also passiert der Fehler höchstwarscheinlich
in Squirrelmail. Ein Problem im Server ist aber nicht 100%ig
auszuschließen, dafür solltest Du aber im Telnet auf Port 25
testen und nicht mit:

[...]
echo pong | mail -s ping root



Das Mail-Kommando umgeht i.d.R. Sachen wie Content-Filter etc.
Das aktuelle Squirrelmail hat definitiv kein solches Problem,
also einfach mal updaten, was ohnehin nichts schaden kann, und
dann ggf. noch ein Plugin nach dem anderen deaktivieren. Ich
könnte mir vorstellen, dass irgendeine Erweiterung nicht sauber
mit der verwendeten sqml-Version zusammenarbeitet.

-Christian

Ähnliche fragen