E-SATA-HD nachträglich anmelden

14/09/2012 - 22:23 von А. Воgnеr | Report spam
Gibt es eine Möglichkeit eine E-SATA-HD (Hitachi HDS5C3020ALA632)
nachtràglich an ein Asrock 970 Extreme4 -
http://www.asrock.com/mb/overview.d...&Model—0%20Extreme4
nachtràglich anzumelden? Bis jetzt kam mir nur 1 Board unter, bei dem
die HD nachtràglich automatisch erkannt wurde.

In diesem Fall habe ich aber das Problem, dass das System bei
angeschlossener ESATA-HD nicht bootet. Vielleicht liegt es daran, dass
das System ebenfalls auf einer Hitachi (Hitachi HDS722020ALA330) liegt.
Im EFI ist die HDS722020ALA330 zum Booten eingestellt. Mit einem
anderen PC habe ich keine Probleme das System mit von Anfang
eingeschalteter HDS5C3020ALA632 zu booten, da wird allerdings von einer
PATA-HD gebootet.

uname -r
3.2.0-30-generic

cat /etc/issue
Ubuntu 12.04.1 LTS \l

extra auf das neueste Bios geflasht:
dmidecode -s bios-version
P2.00


Αl
 

Lesen sie die antworten

#1 Manfred Schmitt
15/09/2012 - 08:58 | Warnen spam
А. Воgnеr schrieb:

Gibt es eine Möglichkeit eine E-SATA-HD (Hitachi HDS5C3020ALA632)
nachtràglich an ein Asrock 970 Extreme4 -
http://www.asrock.com/mb/overview.d...&Model—0%20Extreme4
nachtràglich anzumelden? Bis jetzt kam mir nur 1 Board unter, bei dem
die HD nachtràglich automatisch erkannt wurde.



Ja, das geht indem man einen Bus-Scan ausloest.
Prinzipiell (das muss natuerlich alles auf Deine Gegebenheiten angepasst
werden) so in etwa:
echo "0 0 0" > /sys/class/scsi_host/host0/scan

Und zum sauberen entfernen dann (natuerlich nachdem man die Partitionen
entmountet hat):
# Erst einmal zur Sicherheit die Platte herunterfahren
hdparm -y /dev/sdb
(Hm, mit -Y wuerde die Platte ja noch weiter herunterfahren. In meinem
einige Jahre altem Skript steht aber -y)
# Und dann vom Bus trennen
echo x > /sys/bus/scsi/devices/0:0:0:0/delete

In diesem Fall habe ich aber das Problem, dass das System bei
angeschlossener ESATA-HD nicht bootet. Vielleicht liegt es daran, dass
das System ebenfalls auf einer Hitachi (Hitachi HDS722020ALA330) liegt.
Im EFI ist die HDS722020ALA330 zum Booten eingestellt. Mit einem
anderen PC habe ich keine Probleme das System mit von Anfang
eingeschalteter HDS5C3020ALA632 zu booten, da wird allerdings von einer
PATA-HD gebootet.



Erstaunlich das bei einem so aktuellem Rechner (mit EFI) noch solche
Probleme mit SATA (in Kombination mit P-ATA?) auftreten.

extra auf das neueste Bios geflasht:
dmidecode -s bios-version
P2.00



Tja, Asrock oder was soll man dazu sagen? ;-(

Und wech,
Manne

Ähnliche fragen