easy_install will nicht installieren

31/03/2008 - 22:08 von Carsten Kosthorst | Report spam
Hallo,

ich benutzte heute zum ersten Mal easy_install:

ckone:~# easy_install --dry-run Lyntin
Searching for Lyntin
Reading http://pypi.python.org/simple/Lyntin/
Reading http://lyntin.sourceforge.net/
Reading http://sourceforge.net/project/show...roup_idg30
Best match: lyntin 4.2
Downloading
http://downloads.sourceforge.net/ly...gz?modtime99992999&big_mirror=0
Processing lyntin-4.2.tar.gz
Running lyntin-4.2/setup.py -n -q bdist_egg --dist-dir
/tmp/easy_install-op8QSg/lyntin-4.2/egg-dist-tmp-ZQnf_l
warning: install_lib: 'build/lib' does not exist -- no Python modules to
install
zip_safe flag not set; analyzing archive contents...

Handelt es sich um ein Problem von easy_install oder um ein Problem des
zu installierenden Packages?

<http://www.google.de/search?hl=de&a...;meta=>
hat mir nicht weitergeholfen.

Gruß,

Carsten
 

Lesen sie die antworten

#1 Diez B. Roggisch
01/04/2008 - 11:14 | Warnen spam
Carsten Kosthorst wrote:

Hallo,

ich benutzte heute zum ersten Mal easy_install:

ckone:~# easy_install --dry-run Lyntin
Searching for Lyntin
Reading http://pypi.python.org/simple/Lyntin/
Reading http://lyntin.sourceforge.net/
Reading http://sourceforge.net/project/show...roup_idg30
Best match: lyntin 4.2
Downloading



http://downloads.sourceforge.net/ly...gz?modtime99992999&big_mirror=0
Processing lyntin-4.2.tar.gz
Running lyntin-4.2/setup.py -n -q bdist_egg --dist-dir
/tmp/easy_install-op8QSg/lyntin-4.2/egg-dist-tmp-ZQnf_l
warning: install_lib: 'build/lib' does not exist -- no Python modules to
install
zip_safe flag not set; analyzing archive contents...

Handelt es sich um ein Problem von easy_install oder um ein Problem des
zu installierenden Packages?



Dir ist bewusst das "--dry-run" dafuer sorgt, das nicht wirklich was
passiert? Womit es klar ist, das Folgefehler auftreten koennen?

Nachdem ich mir mal mittels virtualenv ein ein wegwerf-python gemacht habe,
sieht's bei mir ohne dry-run so aus:


(foo):/tmp/foo$ bin/easy_install Lyntin
Searching for Lyntin
Reading http://pypi.python.org/simple/Lyntin/
Reading http://lyntin.sourceforge.net/
Reading http://sourceforge.net/project/show...roup_idg30
Best match: lyntin 4.2
Downloading
http://downloads.sourceforge.net/ly...gz?modtime99992999&big_mirror=0
Processing lyntin-4.2.tar.gz
Running lyntin-4.2/setup.py -q
bdist_egg --dist-dir /tmp/easy_install-aWoLyw/lyntin-4.2/egg-dist-tmp-kkHP8E
zip_safe flag not set; analyzing archive contents...
lyntin.modules.__init__: module references __file__
lyntin.modules.testsystem.testmodule: module references __file__
Adding lyntin 4.2 to easy-install.pth file
Installing runlyntin script to /tmp/foo/bin

Installed /tmp/foo/lib/python2.5/site-packages/lyntin-4.2-py2.5.egg
Processing dependencies for Lyntin
Finished processing dependencies for Lyntin
(foo):/tmp/foo$


Also denke ich mal ist das dry-run wirklich das Problem - und damit der Teil
vor der Tastatur, nicht dahinter :)

diez

Ähnliche fragen