Forums Neueste Beiträge
 

Ehemalige Raid-Partition weigert sich, wieder "normal" zu werden

20/10/2007 - 17:29 von Gr!scha S+egemann | Report spam
Hallo zusammen

Eine ehemalige Software-Raid-Partition möchte ich wieder
als "normale" Partition benutzen. Den Partitionstyp habe ich mit
cfdisk von ehemals 'FD' wieder auf '83' geàndert und mit
mkreiserfs ein Dateisystem darauf erzeugt. Soweit alles ohne
Probleme.

Wenn ich die Partition nun schlicht mounten möchte, dann meckert
mount: unknown filesystem type 'linux_raid_member'

Zudem sagt auch vol_id nachwievor ganz standhaft:
ID_FS_USAGE=raid
ID_FS_TYPE=linux_raid_member
ID_FS_VERSION=0.90.0

Wenn ich mount ein '-t reiserfs' mitgebe, dann wird auch
anstandslos gemountet. Dummerweise wird aber zu dieser
vermeindlichen Raid-Partition kein Link in /dev/disk/by-uuid/
angelegt, so dass ich sie nicht in der fstab "sauber" über die
UUID ansprechen kann.

Wie mache ich dem System (Kubuntu Feisty, kernel 2.6.20) klar,
dass das KEINE Raid-Partition mehr ist?

Danke für jeden Tipp,
Grischa
 

Lesen sie die antworten

#1 Christian Froese
20/10/2007 - 18:50 | Warnen spam
Gr!scha S+egemann wrote:
Hallo zusammen

Eine ehemalige Software-Raid-Partition möchte ich wieder
als "normale" Partition benutzen. Den Partitionstyp habe ich mit
cfdisk von ehemals 'FD' wieder auf '83' geàndert und mit
mkreiserfs ein Dateisystem darauf erzeugt. Soweit alles ohne
Probleme.

Wenn ich die Partition nun schlicht mounten möchte, dann meckert
mount: unknown filesystem type 'linux_raid_member'

Zudem sagt auch vol_id nachwievor ganz standhaft:
ID_FS_USAGE=raid
ID_FS_TYPE=linux_raid_member
ID_FS_VERSION=0.90.0

Wenn ich mount ein '-t reiserfs' mitgebe, dann wird auch
anstandslos gemountet. Dummerweise wird aber zu dieser
vermeindlichen Raid-Partition kein Link in /dev/disk/by-uuid/
angelegt, so dass ich sie nicht in der fstab "sauber" über die
UUID ansprechen kann.

Wie mache ich dem System (Kubuntu Feisty, kernel 2.6.20) klar,
dass das KEINE Raid-Partition mehr ist?

Danke für jeden Tipp,
Grischa



Hi!

Probier mal: "mdadm --zero-superblock /dev/XXXXXXX"


MfG
Christian

Ähnliche fragen