Eindeutige Zellen Suchen und Ihren Inhalt an andere Stelle kopiere

29/09/2008 - 22:30 von biewl | Report spam
Hallihallo,

mein Problem ist folgendes:
Ich habe eine Spalte mit Namen, die doppelt vorkommen können z.B.:

Müller
Schmitt
Zimmermann
Müller
Müller
Schmitt

Ich möchte nun mit einer Formel die eindeutigen Namen herausfinden und diese
in die Spalte nebenan kopieren, so dass es folgendermaßen ausschaut:
Müller
Schmitt
Zimmermann

Wie kann ich das Lösen!
Vielen Dank schonmal!

mfg,
Dominik
 

Lesen sie die antworten

#1 Klaus \Perry\ Pago
29/09/2008 - 23:36 | Warnen spam
Hallo Dominik,

"biewl" schrieb im Newsbeitrag
news:
Hallihallo,

mein Problem ist folgendes:
Ich habe eine Spalte mit Namen, die doppelt vorkommen können z.B.:

Müller
Schmitt
Zimmermann
Müller
Müller
Schmitt

Ich möchte nun mit einer Formel die eindeutigen Namen herausfinden und
diese
in die Spalte nebenan kopieren, so dass es folgendermaßen ausschaut:
Müller
Schmitt
Zimmermann



ich möchte folgende Matrixformel-Lösung anbieten.
Deine Daten stehen in A2 bis A200

B2: =WENN(ZEILE(A1)>ANZAHL(WENN(VERGLEICH($A$2:$A$200&" ";$A$2:$A$200&"
";0)=ZEILE($1:$199);ZEILE($1:$199)))-1;"";INDEX(A$2:A$200;KKLEINSTE(WENN(VERGLEICH($A$2:$A$200&"
";$A$2:$A$200&" ";0)=ZEILE($1:$199);ZEILE($1:$199));ZEILE(A1))))
die Formel mit der Drei-Tasten-Kombination CTRL SHIFT RETURN eingeben -
Excel setzt dann geschweifte Klammern { }
und bis maximal B200 herunterkopieren. Die Bereiche können leicht in der
Formel angepasst werden.

Hinweis: Bei langen Listen können bedingt durch die Matrix-Formeln lange
Rechenzeiten entstehen.
Gruß
Klaus

Ähnliche fragen