Eindeutiger Wert in Spalte

15/04/2008 - 23:29 von Joerg Hermes | Report spam
Hallo,

Die Zellen A1 bis A50 sollen eine Zahl höchstens einmal enthalten
(Seriennummer). Hierzu setze ich im Menü "Daten->Gültigkeit" die
benutzerdefinierte Formel =ZÄHLENWENN($A$1:$A$50;A1)=1 und im Reiter
Fehlermeldung ein Hàkchen. Wieso funktioniert das? Die Gültigkeitsbedingung
ist doch erfüllt, wenn der Wert aus A1 nicht ein zweites mal vorkommt, aber
die Fehlermeldung erscheint wie eigentlich beabsichtigt auch dann, wenn ich
in beliebige zwei andere Zellen in der A-Spalte den selben Wert eingebe.

Gruß
Jörg
 

Lesen sie die antworten

#1 Robert Gelbmann
16/04/2008 - 00:27 | Warnen spam
Hallo Joerg!

"Joerg Hermes" schrieb ...
Die Zellen A1 bis A50 sollen eine Zahl höchstens einmal enthalten
(Seriennummer). Hierzu setze ich im Menü "Daten->Gültigkeit" die
benutzerdefinierte Formel =ZÄHLENWENN($A$1:$A$50;A1)=1 und im
Reiter Fehlermeldung ein Hàkchen. Wieso funktioniert das? Die
Gültigkeitsbedingung ist doch erfüllt, wenn der Wert aus A1 nicht
ein zweites mal vorkommt, aber die Fehlermeldung erscheint wie
eigentlich beabsichtigt auch dann, wenn ich in beliebige zwei
andere Zellen in der A-Spalte den selben Wert eingebe.



Die bei der Datengültigkeit eingegebene Formel enthàlt mit A1 einen
relativen Bezug (statt absolut: $A$1).
Dabei war offensichtlich bei der Einrichtung der Datengültigkeit die
Zelle A1 die aktive Zelle.

Mit A1 (relativ!) in der Formel ist daher nicht die fixe Zelle A1
(oder vielmehr: $A$1) adressiert, sondern die jeweilige Zelle (in A1
die Zelle A1, in A2 die Zelle A2 usw.).

Excel kopiert quasi deine Formel in die übrigen Zellen und passt
dabei die (relativen) Bezüge genau so an, wie beim Kopieren von
Formeln in Zellen.

In der Hoffnung geholfen zu haben, verbleibe ich mit einem leisen


Servus aus Wien,
-Robert Gelbmann-

I solemnly swear that I'm up to no good.

Ähnliche fragen