Einige X-Anwendungen starten nicht

25/10/2007 - 10:17 von Ralph Sontag | Report spam
Ein höchst unbefriedigendes Verhalten einiger Programme der OpenSuse 10.3
harrt einer Lösung:

Die Nutzerverzeichnisse wurden übernommen, sind also mit früheren Einstellungen
z.T. verseucht.

In diesem Umfeld weigerten sich tuxpaint und openttd zu starten, xine
startete, nahm aber keinerlei Befehle entgegen. Andere Programme hingegen
starteten ohne zu zicken.
Meine Intuition führte mich zu .Xauthority. Abmelden, Löschen des Files und
Neuanmelden schienen zunàchst zu helfen, dann trat das Problem erneut auf
und diesmal versagte der Trick.

Merkwürdigerweise konnte ich tuxpaint einmal starten, beim zweiten Mal
ging's dann wieder nicht.
Nun bin ich mir nicht mehr sicher, ob das .Xauthority aus dem alten $HOME
tatsàchlich schuldig ist. Aber wo sonst könnte man noch suchen?

Die verschwommenen Begleitumstànde machen den Fehler zu einer Freude für
jeden Supportwilligen. In /var/log gab es keine Hinweise, weder in messages
noch in den X-logs. Im Home in .xsession-errors gab es eine Meldung, die
mich auf die Idee brachte, im .Xauthority-Umfeld zu suchen. (Und wenn ich
meine Sinne beisammen gehabt hàtte, könnte ich die jetzt auch hier mit
posten - sie liegt aber zu Hause.)

Na, vielleicht hat jemand besser Intuition als ich.

Gruß!
Ralph.

1.-2. 3. 2008: Chemnitzer Linux-Tage 2008 http://chemnitzer.linux-tage.de/
 

Lesen sie die antworten

#1 Lisa Denia
26/10/2007 - 01:58 | Warnen spam
Am Thu, 25 Oct 2007 08:17:06 +0000 schrieb Ralph Sontag:

Ein höchst unbefriedigendes Verhalten einiger Programme der OpenSuse
10.3 harrt einer Lösung:

Die Nutzerverzeichnisse wurden übernommen, sind also mit früheren
Einstellungen z.T. verseucht.

In diesem Umfeld weigerten sich tuxpaint und openttd zu starten, xine
startete, nahm aber keinerlei Befehle entgegen. Andere Programme
hingegen starteten ohne zu zicken.
Meine Intuition führte mich zu .Xauthority. Abmelden, Löschen des Files
und Neuanmelden schienen zunàchst zu helfen, dann trat das Problem
erneut auf und diesmal versagte der Trick.

Merkwürdigerweise konnte ich tuxpaint einmal starten, beim zweiten Mal
ging's dann wieder nicht.
Nun bin ich mir nicht mehr sicher, ob das .Xauthority aus dem alten
$HOME tatsàchlich schuldig ist. Aber wo sonst könnte man noch suchen?

Die verschwommenen Begleitumstànde machen den Fehler zu einer Freude für
jeden Supportwilligen. In /var/log gab es keine Hinweise, weder in
messages noch in den X-logs. Im Home in .xsession-errors gab es eine
Meldung, die mich auf die Idee brachte, im .Xauthority-Umfeld zu suchen.
(Und wenn ich meine Sinne beisammen gehabt hàtte, könnte ich die jetzt
auch hier mit posten - sie liegt aber zu Hause.)

Na, vielleicht hat jemand besser Intuition als ich.

Gruß!
Ralph.



Hallo Ralph,

ich persönlich schàtze mal das die Programme nun in einer neueren Version
vorhanden sind und evtl. nicht mehr mit der alten Konfiguration
zurechtkommen und deshalb mist bauen. Es sollte helfen z.B. /home/
deinusername/.tuxpaint zu löschen.

Gruß,
Lisa Denia

Ähnliche fragen