Einsatzkalender - Bedingte Formatierung und Summenprodukt

16/09/2007 - 11:51 von Ralf Brinkmann | Report spam
Hallo Alle!

Ich möchte für Excel 2003 mal wieder einen Einsatzkalender entwerfen,
aber nicht nur für mich, sonder für unterschiedliche Kollegen. Daher
muss ich die Sachen etwas allgemein halten.

Also (Name des Arbeitsblattes ist die jeweilige Jahreszahl, also jetzt
2007):

W i e o f t

1 2 3 4 5 6 7 8 9
Müller
Meyer
Schulze
...

Datum von bis Name Stunden
Mo 01. 01.
Di 02. 01.
Mi 03. 01.
...
Mo 05. 02.
Di 06. 02.
Mi 07. 02.
...

Oben links sollen die Verantwortlichen die Namen ihrer Mitarbeiter
(maximal 5) eintragen und nach eigenen Wünschen formatieren. Das erste
Datum ist der erste Januar des Blattnamens (2007), der Rest baut darauf
auf. Die Spalten enthalten waagerecht immer dasselbe Datum, nur
unterschiedlich formatiert.

Nun möchte ich die Spalte mit den Namen (hinter von bis) formatieren:
Guck nach, ob der Name mit dem oben links übereinstimmt, wenn ja, dann
formatiere genauso. Mit bedingter Formatierung wird das wohl nicht
gehen, oder?

Falls VBA erforderlich ist, wie geht es dann? Ich nehme allerdings VBA
nicht so gerne, weil ich es a) selbst nicht beherrsche und b) unser
Netzwerk sowas beim Versenden immer als Virus "erkennt".

Weiterhin möchte ich oben in den Zellen unter "Wie oft" anzeigen lassen,
wie oft jeder pro Monat dran war. Ich habe es schon probiert mit der
Formel '=SUMMENPRODUKT((MONAT(C13:C378)=1)*(F13:F378="Müller"))' (Spalte
C ist die Monatsspalte, Spalte F die mit den Namen untereinander), aber
da bekomme ich immer die Fehlermeldung #WERT!. Ich finde leider den
Fehler nicht (in der endgültigen Version würde ich dann statt des Namens
wieder die absolute Zellenbezeichnung eintragen).

Hat jemand eine Idee?

Gruß, Ralf
 

Lesen sie die antworten

#1 Alexander Wolff
16/09/2007 - 12:10 | Warnen spam
Mit bedingter Formatierung bekommst Du vor xl2007 nur 4 Formate hin. ...

Oben links sollen die Verantwortlichen die Namen ihrer Mitarbeiter
(maximal 5) eintragen und nach eigenen Wünschen formatieren. Das erste


...
Guck nach, ob der Name mit dem oben links übereinstimmt, wenn ja, dann
formatiere genauso. Mit bedingter Formatierung wird das wohl nicht
gehen, oder?



... Außerdem wird es statisch vergeben, nicht aufgrund einer anderen
Formatierung.

Ich vermute, dass letztere Einschrànkung auch für xl2007 gilt.

Daher wàre VBA (oder eine genügsamere Entscheidung bezüglich der Optik) die
Wahl.
Moin+Gruss Alexander - MVP für MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen