Erbitte LTSpice Hilfe tu ZTX415

22/11/2009 - 01:00 von Harald Noack | Report spam
Hallo!

Ich möchte den ZTX415 in einer Simulation einbauen, bekomme aber nur einen
Missing-Node-Fehler bei der .include Directive.

Als Transistor habe ich den NPN eingefügt und in ZTX415 umbenannt.

Spice-Modell: http://www.diodes.com/products/cata...hp?item-id‚6#

Danke für Eure Hilfe!
Mit freundlichen Grüßen
Harald Noack


*.asc File

Version 4
SHEET 1 2172 680
WIRE 528 -64 256 -64
WIRE 256 -48 256 -64
WIRE 528 -32 528 -64
WIRE 256 112 256 32
WIRE 384 112 256 112
WIRE 256 144 256 112
WIRE 384 144 384 112
WIRE 192 192 128 192
WIRE 256 272 256 240
WIRE 256 272 128 272
WIRE 256 304 256 272
WIRE 256 400 256 384
WIRE 384 400 384 208
WIRE 528 400 528 48
FLAG 256 400 0
FLAG 384 400 0
FLAG 528 400 0
SYMBOL npn 192 144 R0
SYMATTR InstName Q1
SYMATTR Value ZTX415
SYMBOL res 112 176 R0
SYMATTR InstName R1
SYMATTR Value 1k
SYMBOL cap 368 144 R0
SYMATTR InstName C1
SYMATTR Value 100p
SYMBOL res 240 -64 R0
SYMATTR InstName R3
SYMATTR Value 100k
SYMBOL voltage 528 -48 R0
WINDOW 123 0 0 Left 0
WINDOW 39 0 0 Left 0
SYMATTR InstName V1
SYMATTR Value 500V
SYMBOL res 240 288 R0
SYMATTR InstName R2
SYMATTR Value 10R
TEXT -120 -64 Left 0 !.tran 0 200u 0 startup
TEXT -120 -96 Left 0 !.inc C:\\Spice\\Spicemodel_ZTX415.txt
 

Lesen sie die antworten

#1 Helmut Sennewald
22/11/2009 - 12:44 | Warnen spam
"Harald Noack" schrieb im Newsbeitrag
news:5148d$4b087f5e$d52f2bc6$
Hallo!

Ich möchte den ZTX415 in einer Simulation einbauen, bekomme aber nur einen
Missing-Node-Fehler bei der .include Directive.

Als Transistor habe ich den NPN eingefügt und in ZTX415 umbenannt.

Spice-Modell:
http://www.diodes.com/products/cata...hp?item-id‚6#

Danke für Eure Hilfe!
Mit freundlichen Grüßen
Harald Noack



Hallo Harald,

Das Modell ist ein subcircuit. Deshalb muss LTspice beim Generieren der
Netzliste
das berücksichtigen.
Schau mal da rein: View -> SPICE Netlist

Cursor über das Bauteil fahren.
Ctrl plus rechte Maustate klicken.
Im Dialogfenster: Prefix:Qn
das QN durch X ersetzen.
Prefix:X

OK

Diese Vorgehensweise braucht man auch für die Modelle von Power-Mosfets
und manchmal auch für Dioden. Eben immer, wenn man ein Symbol hat das für
".model" gedacht ist, man es aber für ein Subcircuit verwenden will ohne ein
extra Symbol zu machen.

Gruß
Helmut

Ähnliche fragen