Ereignisprogrammierung: Zeile löschen

01/03/2009 - 08:41 von Pascal Roches | Report spam
WinXP/Excel03

Hallo Leute
Ich habe eine Frage zum Thema Ereignisprogrammierung in VBA.
Ich möchte abfangen, wenn ich eine ganze Zeile in einem Worksheet
lösche. Soviel ich weiss gibt es zum Löschen von Ranges keine
vordefinierten Events.

Kann ich hierfür eine eigenes Ereignis selbst programmieren? Oder wie
empfehlt ihr, hier vorzugehen?

Besten Dank für Eure Antworten
Pascal
 

Lesen sie die antworten

#1 Alexander Wolff
02/03/2009 - 18:31 | Warnen spam
Die Tastatur von Pascal Roches wurde wie folgt gedrückt:
WinXP/Excel03

Hallo Leute
Ich habe eine Frage zum Thema Ereignisprogrammierung in VBA.
Ich möchte abfangen, wenn ich eine ganze Zeile in einem Worksheet
lösche. Soviel ich weiss gibt es zum Löschen von Ranges keine
vordefinierten Events.

Kann ich hierfür eine eigenes Ereignis selbst programmieren? Oder wie
empfehlt ihr, hier vorzugehen?



Wenn Du vor (im Sinne von _Change also eher danach) dem Löschen eine Spalte
(A) mit lfdNr (siehe auch Thread von 2.3. 13:58, meine Antwort dort)
einfügst, mit deren Werten überkopierst und diese Reihe nach einem
Worksheet_Change mit =SUMMENPRODUKT(--(A1:A998+1¢:A999))>0 auf WAHR oder
FALSCH hin untersuchst, bist Du auf dem richtigen Weg.

Antwort also: Innerhalb von _Change prüfen, kein eigenes Ereignis nötig.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen