Erfreuliches und Stolpersteine bei 10.3 Installation

06/10/2007 - 10:44 von Olaf Meltzer | Report spam
Gestern bin ich von 10.2 auf 10.3 gewechselt. Verwendet wurde die
GM-DVD für i386 vom 4. Oktober.

Vorweg schon mal ein erfreuliches Fazit: Alle wichtigen Komponenten
wurden sofort erkannt und konnten mit Yast konfiguriert werden. Der
Rechner stand also sofort wieder zur Arbeit bereit, einschließlich
Internet und beiden Druckern.

Rechner:
Selbstbau mit ASUS MB, AMD 2400, 1GB, NVIDIA 6600/256MB

Alles wurde als solches erkannt, aber für die Grafikkarte wurde
zunàchst nicht der Original-Treiber installiert, sondern ein Ersatz.
Dieser funktioniert für Büroarbeiten ausreichend gut. An der
Schriftdarstellung hab ich jedenfalls nichts zu bemàkeln.

Sound-Karten:
Creative Labs SB Live Digital, M-Audio Delta Audiophile 2496
(OnBoard-Sound ist im BIOS deaktiviert)

Beide Karten wurden als solche erkannt und ließen sich mit Yast
konfigurieren.

TV-Karten:
Hauppauge Nexus DVB-S, Terratec Cinergy 1600 DVB-T

Nur die Nexus wurde erkannt.

Drucker:
Brother HL-2040, Canon PIXMA i4000

Beide wurden erkannt, für den Brother gibt es aber via Yast nur die
Möglichkeit ihn als HL-2060 zu betreiben. Das funktioniert im
Prinzip, nur die Größe des Ausdrucks ist minimal zu groß. Der Canon
PIXMA wurde jetzt erstmals für mich ohne kommerzielle Treiber unter
Linux benutzbar. Es werden anscheinend alle Funktionen unterstützt.
Der erste Testausdruck war jedenfalls wirklich gut.

Scanner:
Epson Photo 1670 (Flachbett), Minolta Dimage III (Dia/Negativ)

Hab ich noch nicht probiert.

DER INSTALLATIONSVERLAUF


Man streitet ja darüber was beim Update besser sei: Bis auf die
eigenen Dateien alles neu zu installieren, oder das neue System
frohgemut und blauàugig über das alte drüberzubügeln, wobei dann
meistens nicht mehr benötigter Schrott übrigbleibt, und mit hoher
Wahrscheinlichkeit erst einmal jede Menge Konflikte manuell aufgelöst
werden müssen. Ich habe mit beiden Varianten meine eigenen unguten
Erfahrungen gemacht. Diesmal wàhlte ich eine Neuinstallation. Das
alte System wurde vorher komplett gesichert. Die Home-Partition hab
ich belassen (keine Formatierung!), die System-Partition hab ich
wàhrend der Installation zur Formatierung freigegeben.

Erster Versuch

Es wurde berichtet, daß man schon wàhrend der Installation externe
Quellen (Repositories) mit einbinden könne. Das hab ich dahingehend
mißverstanden, daß dafür die bereits ziemlich zu Beginn angebotene
Auswahlmöglichkeit zustàndig sei. Aktiviert man dies, werden die
_bisher_ benutzten Repositories aufgelistet, aber sie sind alle
deaktiviert. Naiverweise hab ich dort in den Pfaden alles von 10.2
auf 10.3 umgestellt und die Repos aktiviert. Nachfolgend wurde dann
versucht, diese Quellen zu erkennen, was fehlschlug. Jedenfalls
deutete ich das ewige Verweilen ohne sichtbaren Fortschritt so. Ich
konnte dies Aktion auch nicht abbrechen, um es erst einmal ohne
weitere Quellen versuchen: Keine Reaktion. Ich hab dann resettet.

Zweiter Versuch

Nun ohne _bisherige_ Repositories, aber immerhin bereits mit aktuellen
Online-Quellen. Das Einbinden der "Hauptquelle NON-OSS" lief ruckzuck
durch, aber bei der "Hauptquelle OSS" hakte es mitunter. An dieser
Stelle darf man nicht die Geduld verlieren. Abbruch ist auch hier
unmöglich. Eine Fehlermeldung "Timeout" erscheint erst jeweils nach 3
Minuten. Wenn man diese mit OK bstàtigt gibt es die
3fach-Auswahl "Wiederholen/Abbruch/Überspringen". Auch hier
funktionierte weder Abbruch noch Überspringen, aber Wiederholen
führte in jedem Fall zum unmittelbaren Erfolg -- bis zu nàchsten
Hànger. Auf diese Weise dauerte das Einbinden der "Hauptquelle OSS"
über eine halbe Stunde. Weiterhin lief dann alles glatt.

Bei der Netzwerk-Konfiguration wàhlte ich alte Methode mit ifup und
DHCP. Dort aktivierte ich auch die Auswahl Rechnernamen anzeigen, in
der irrigen Annahme, das meine den von mir gewàhlten Rechnernamen.
Das führte aber dazu, daß spàter im Prompt die dynip statt des
Rechnernamens erschien. Ich konnte das dann nachtràglich im
sysconfig-Editor bereinigen.

Das Einbinden externer Quellen

Hierfür gibt es nun einen eigenen Bereich im Yast: "Community Repos".
Hier reicht dann ein Mausklick und Tippfehler bei Pfadeingaben werden
also vermieden. Diese Quellen (typischerweise Packman) werden nicht
mehr wie bisher über "Installationsquelle wechseln" eingebunden. Nur
Quellen, die nicht als Community Repo aufgelistet sind, benötigen den
alten Weg.

Gruß -- Olaf Meltzer
 

Lesen sie die antworten

#1 Martin Schnitkemper
06/10/2007 - 11:30 | Warnen spam
· Olaf Meltzer schrieb:

Gestern bin ich von 10.2 auf 10.3 gewechselt. Verwendet wurde die
GM-DVD für i386 vom 4. Oktober.



Kannst du "smart" über das Menü oder eine Verknüpfung aufrufen? Bei mir wird
der Aufruf nicht vollstàndig an kdesu übergeben.

Martin.

Ähnliche fragen