Forums Neueste Beiträge
 

erweiterte SVERWEIS-Funktion

08/09/2007 - 14:20 von Markus Franz | Report spam
Hallo,



ich habe ein Tabellenblatt, in welchem ich eine Spalte „Bearbeiternummer“
und „Bearbeiter“ habe. Sobald ich in Spalte „Bearbeiternummer“ als Ziffer
<<1>> eintrage, erscheint unter „Bearbeiter“ dann z.B. <<Mustermann>>. Die
Tabelle, in welcher festgelegt ist, dass Herr Mustermann die Nummer 1 hat,
liegt auf einem anderen Tabellenblatt (dort ist unter Spalte B ab Zeile 3
die Nummer und Spalte C ab Zeile 3 der entsprechende Name. Die
Namenscodetabelle umfasst ca. 100 Eintragungen.



An sich ist das ja mittels SVERWEIS-Funktion ohne weiteres lösbar.



Nun möchte ich in meiner Tabelle gern folgendes Problem lösen:



Manchmal kommt es vor, dass mehr als 1 Bearbeiter eingetragen werden soll.
Sofern möglich, möchte ich z.B. bei „Bearbeiternummer“ als Ziffer <<1,2>>
oder auch mit Leerzeichen (<<1, 2>>) eintragen und bei Bearbeiter soll dann
<<Mustermann, Müller>> erscheinen. Die Funktion müsste so sein, dass auch
mehrere Zahlen erfasst werden können (z.B. <<1,5,7,19>> bzw. <<1, 5, 7,
19>>). Damit dürfte die SVERWEIS-Funktion nicht mehr funktionieren. Die
entsprechenden Daten soll er sich aus der Namenscodetabelle holen.



Hat jemand eine Idee, wie man so was lösen kann?



Vielen Dank für etwaige Lösungen.



Gruß

Markus
______________________________
Windows XP (SP2),
Office 2000



Antworten bitte ausschließlich in der Newsgroup!
 

Lesen sie die antworten

#1 Klaus \Perry\ Pago
08/09/2007 - 16:21 | Warnen spam
"Markus Franz" schrieb im Newsbeitrag
news:fbu48j$77t$03$
Hallo,



ich habe ein Tabellenblatt, in welchem ich eine Spalte "Bearbeiternummer"
und "Bearbeiter" habe. Sobald ich in Spalte "Bearbeiternummer" als Ziffer
<<1>> eintrage, erscheint unter "Bearbeiter" dann z.B. <<Mustermann>>. Die
Tabelle, in welcher festgelegt ist, dass Herr Mustermann die Nummer 1 hat,
liegt auf einem anderen Tabellenblatt (dort ist unter Spalte B ab Zeile 3
die Nummer und Spalte C ab Zeile 3 der entsprechende Name. Die
Namenscodetabelle umfasst ca. 100 Eintragungen.



An sich ist das ja mittels SVERWEIS-Funktion ohne weiteres lösbar.



Nun möchte ich in meiner Tabelle gern folgendes Problem lösen:



Manchmal kommt es vor, dass mehr als 1 Bearbeiter eingetragen werden soll.
Sofern möglich, möchte ich z.B. bei "Bearbeiternummer" als Ziffer <<1,2>>
oder auch mit Leerzeichen (<<1, 2>>) eintragen und bei Bearbeiter soll
dann <<Mustermann, Müller>> erscheinen. Die Funktion müsste so sein, dass
auch mehrere Zahlen erfasst werden können (z.B. <<1,5,7,19>> bzw. <<1, 5,
7, 19>>). Damit dürfte die SVERWEIS-Funktion nicht mehr funktionieren. Die
entsprechenden Daten soll er sich aus der Namenscodetabelle holen.



Hat jemand eine Idee, wie man so was lösen kann?



Hallo Markus,

meine Lösung ist etwas umstàndlich und benötigt viele Hilfszellen. Ich habe
sie für 10 Zahlen ausgelegt.

In Tabelle2 befinden sich in B3 bis C100 die Nummern und Namen.

Tabelle1:
A1: Eingabe der Nummern zB 1,5,7,19 oder 1, 5, 7, 19 (bis zu 10 Nummern
werden erkannt

B1: =WENN(ISTFEHLER(AR1);"";AR1)&WENN(ISTFEHLER(AS1);"";",
"&AS1)&WENN(ISTFEHLER(AT1);"";", "&AT1)&WENN(ISTFEHLER(AU1);"";",
"&AU1)&WENN(ISTFEHLER(AV1);"";", "&AV1)&WENN(ISTFEHLER(AW1);"";",
"&AW1)&WENN(ISTFEHLER(AX1);"";", "&AX1)&WENN(ISTFEHLER(AY1);"";",
"&AY1)&WENN(ISTFEHLER(AZ1);"";", "&AZ1)&WENN(ISTFEHLER(BA1);"";", "&BA1)

C1: =WECHSELN(WECHSELN("#"&A1&"#";",";"#");" ";"")

D1:
=KKLEINSTE(WENN(TEIL($C$1;ZEILE($1:$50);1)="#";ZEILE($1:$50));SPALTE(A1))
als Matrixformel mit STRG+SHIFT+RETURN eingeben (sonst klappt es nicht und
bis M1 kopieren

N1:
=KKLEINSTE(WENN(TEIL($C$1;ZEILE($1:$50);1)="#";ZEILE($1:$50));SPALTE(B1))
als Matrixformel mit STRG+SHIFT+RETURN eingeben und bis W1 kopieren

X1: =N1-D1-1 bis AG1 kopieren

AH1: =TEIL($C$1;D1+1;X1)*1 bis AQ1 kopieren

AR1: =SVERWEIS(AH1;Tabelle2!$B$3:$C$100;2;0) bis BA1 kopieren

Fettich :) Das Ergebnis steht in B1

Gruß
Klaus

Ähnliche fragen