[Essay] Linux - Irrfahrt und Verwunderung

03/04/2008 - 16:04 von Fr | Report spam
Hallo zusammen,

vorausschicken möchte ich, dass ich seit Ende 1992 (Linux Kernel 0.99)
konsequent Linux nutze und alles selbst mache. Ich komme gut mit der
Konsole zusammen, habe einen Berg eigener Shellskripte, habe einen
hocheffizienten RAW-Workflow in der Bildbearbeitung, synchronisiere
in kürzerster Zeit meinen sehr umfangreichen Internetauftritt, schreibe
sowohl Korrespondenz als auch Rechnungen mit LaTeX, fotografiere am
Bildschirm immer noch mit xv, schreibe Programme mit Emacs und vi,
tippe auch komplexere for-Schleifen an der Kommandozeile ein, mache
die meiste Systemadministration des lokalen Netzwerks aus dem Kopf
und bin ein Freund der Enter-Taste am Zeilenende.

Having said that ... bekenne ich mich aus voller Überzeugung zu Linux
und habe gelernt, vorhandene Klippen zu umschiffen und Lücken alternativ
zu füllen. Window$ ist für mich kein Maßstab und hat praktisch keine
Relevanz.

Nichtsdestotrotz passieren manchmal Dinge, bei denen ich mich frage,
ob das ehemals robuste Linux inzwischen auf dem besten Wege ist,
ein Ersatzwindow$ zu werden: Der Nutzer wird zunehmend entmündigt,
die Abhàngigkeiten werden immer komplexer und es ist kaum noch
möglich, ein aktuelles System durch eine handvoll selbst editierter
Textdateien zum laufen zu bringen.

Die anfàngliche Begeisterung für die zahllosen Möglichkeiten eines
freien und offenen Systems ließ mich in ein Duzend Programmiersprachen
schnuppern und zeitweise war es so, dass Linux Selbstzweck war: Stàndig
wurde getunt, verbessert, debugged, getraced um die Möglichkeiten des
Systems auszuloten und zu optimieren.

Diese Zeit liegt bei mir schon mehrere Jahre zurück, denn irgendwann
kam es, wie es kommen musste: Ich brauchte ein stabiles System, das
vor allen Dingen eins tut: Laufen! Ich muss mit dem Rechner arbeiten
und Geld verdienen, viel Zeit zum Spielen und Basteln ist nicht.
Das System der Wahl war SuSE-4.2 ... damals und irgendwie bin
ich dabei geblieben. Dass andere anderes anders machen, ist klar,
aber interessiert mich nur noch marginal, solange meine Kiste làuft.

Inzwischen làuft sie auf OpenSuSE-10.3, aber erst seit zwei Tagen,
denn: "Never change a running system". Wie es dazu kam, schrieb ich
gestern in einer privaten Mail. Anschließend dachte ich, dass das
vielleicht auch mal ganz interessant in dieser NG zu lesen sei,
denn Linux ist meine alte Liebe trotz einiger Fragezeichen. Der
folgende Essay ist praktisch wörtlich aus der erwàhnten Privatmail
zitiert und am Ende stehen ein paar Fragen, die ich sehr gerne
beantwortet hàtte .



Stell dir vor: Hab ohne jede Mühe mit (m)einem aktuellen Linux
(OpenSuSE-10.3) den Bàllzisch kopieren können [Anm.: "Bàllzisch"
meint den Erwin Pelzig. Habe eine Original-DVD von ihm unter
Linux kopiert] und sogleich die erste Halbzeit bis zur Pause
beàugt ... dann war es Mitternacht und ich wollte endlich mal
wieder früher ins Bett. Also habe ich an dieser Stelle gestoppt.
Wie es dazu kam, liest du hier ..

Das 10.3-er Linux hat ein wirklich geniales Paketmanagement,
das - wenn du ein bestimmtes Packerl Software brauchst - die
davon abhàngigen oder dadurch bedingten Packerl gleich mitbringt.

Bisher musste man ja immer, oft mühsam und oft genug erfolglos,
das Zeug selber zusammensuchen.

OpenSuSE-10.3 habe ich ja schon seit Monaten auf meinem
Schlepptopp, aber seit gestern Morgen 4:00 Uhr auch auf meinem
Desktop/Produktionssystem.

Hintergrund: Vorgestern Morgen schalte ich meinen konservativ
gepflegten SuSE-10.1 Desktop ein. Am Anmeldebildschirm geht die
Maus nicht .. naja ... ich melde mich ohne an - sie geht immer
noch nicht. Okay: KDE abbrechen, zurück zum Anmeldedeschirm -
immer noch Regungslosigkeit.

Nerv! .. also ribuhten wir halt ... 4 Minuten spàter wieder am
Anmeldebildschirm - nix. Hmm . andere Maus (alte PS/2) ... geht!
Einloggen, arbeiten.

Kurz darauf spinnt die Tastatur [Anm: Wieder PS/2 und nagelneu!
Die Billig-USB-Funktastatur war nur noch nervig!], kann nix mehr
eingeben und jetzt ist auch die Maus wieder entschlafen, hilft
nur Ausschalten und Neustart.

Wieder am Anmeldebildschirm geht garnix, aber die Kiste làuft
immerhin. Gut, da wird wohl ein System-Update sinnvoll sein,
stand eh mal an. Also erstmal den Schlepptopp starten und über
WLAN die Daten des Desktops rüberkopieren, damit ich auf alle
Fàlle weiterarbeiten kann (Datensicherung hatte ich sowieso - wie gut!).

Schleppi einschalten warten warten ... Fehler! Er kommt
nicht hoch!! Wasn jetz lohs??

Nochmal das ganze .. wieder nix. "Media error" heißt die Meldung,
die mich fast erstarren làsst: Sollte gerade in diesem Moment
die Festplatte ihren Geist aufgegeben haben? Ich stehe in der
Konsole am Abbruchs-Login. Okay, logg ich mich halt als "root"
ein und repariere von Hand. Ich tippe "root" und das Passwort
ein abgelehnt! HÎ Vertippt??

Nochmal wieder nix!

Mir wird wàrmer. Ist das der GAU? Starten wir mal Window$ auf
der Kiste. Also neu einschalten und wieder geht nix. Ist
jetzt also doch die Platte im Ärmel? Darf ich mich auf parallele
Neuinstallation zweier Systeme bei zeitgleicher Arbeitsunfàhigkeit
einstellen?

Zuerst mal ganz ruhig - es gibt ja noch den dritten Rechner
im Netz, mein ganz alter. Der làuft. Wie seit Jahren. Der
Bildschirm flackert zwar und er ist eher langsam, aber er làuft.

Übers Netz komme ich an mein Produktionssystem, dessen
Tastatur und Maus nutzlos sind. Ich "hole" mir die
Fenster wichtiger Anwendungen (Email, Opera, Organizer)
rüber auf den "alten" [Anm: $DISPLAY] - ich kann arbeiten!

Ein "Zustand" ist das aber nicht. Wenn ich jetzt mal schnell
was nachgucken muss, dauert es ziemlich lange und das macht
mir Stress. Zudem muss ich auch Rechnungen schreiben und
Drucken ... es geht alles, aber umstàndlich und davon
reparieren sich zwei defekte Systeme natürlich auch nicht selbst.

Also der Reihe nach: Auf dem Laptop ist nix, was existenziell
wàre, den könnte ich zur Not mit zwei neuen Festplatten
bestücken und neu aufsetzen. Vorher starte ich aber noch
ein Rettungssystem von CD ins RAM (keine Festplatten nötig)
und suche nach dem Fehler. Tatsàchlich kann ich nach und
nach die einzelnen Partitionen checken, ein paar Fehler
fixieren und nach kaum einer Stunde làuft er wieder "normal"
hoch. Immerhin. Hoffen wir, dass es das war. Wobei mich ein
gewisses Unbehagen quàlt, weil "Media Error" oft genug den
Anfang vom Ende einer Festplatte signalisiert.

Nun muss ich also den großen Schritt riskieren, meinen
Desktop zu reanimieren. Da ich übers Netz auf die Kiste
zugreifen kann, mounte ich dort nochmal alle Backup-Platten
und synchronisiere sàmtliche Nutzdaten dorthin.

Auf dem [noch funktionstüchtigen] alten Rechner làuft
SuSE-10.1 (i386), also muss ich erst noch ein Image für
SuSE-10.3 (x86_64) downloaden. Dank DSL dauert es keine
zwei Stunden, bis die knapp 5 GB runter geladen sind.
Dann noch die DVD brennen ... dauert auch ein bisschen ...

Am spàten Nachmittag kann ich endlich anfangen, den Desktop
mit OpenSuSE-10.3 zu booten und die Installation nimmt ihren
Lauf. Es geht alles sehr flott, sehr komfortabel. Bei der
Partitionierung mache ich, wie immer, alle System-Partitionen
platt (formatiere sie neu), die Nutzdaten unter "/home" et
al lasse ich ganz.

Bei der Paketauswahl fallen mir noch einige Dinge ein, die
ich gewohnheitsmàßig brauche, wie LaTeX, xv, locate. Danach
dauert es nur knapp zwei Stunden, bis das System installiert,
das Netzwerk (ohne DHCP) konfiguriert, die ehemaligen Benutzer
wieder angelegt, der automatische Emailversand und -empfang
und die NVidia-Grafikkarte mit 3D eingerichtet sind.

Dann kommt noch das Wacom-Grafiktablett an die Reihe und
kurz nach Mitternacht kann ich mit dem Finetuning beginnen:
Neue Gimp-Version (2.4.x - auf dem alten System bekam ich
die nie zum Laufen), dann Opera, Firefox, Thunderbird,
GoogleEarth, Picasa, BibblePro, OpenOffice, Mplayer und
einiges andere installieren und konfigurieren. Ab etwa
3:00 Uhr kann ich mich am neuen, schicken, aufgeràumten
System erfreuen und teste noch die Funktionen einiger für
mich sehr wichtiger Arbeitsschritte:

* Verbindungen im LAN: Drucker, Schlepptopp, usw.
* Datensicherung extern
* meine Shellskripte, die intensiv ImageMagick nutzen
* meine Shellskripte für den Büro-Workflow mit LaTeX
* BibblePro für den RAW-Workflow
* Wacom-Grafiktablett in Gimp
* Streaming Audio/Video mit MPlayer und im Browser

Um 4:00 Uhr mache ich Schluss, alles làuft bis dahin und
es sieht sehr gut aus - ab in die Falle :)

Völlig geràdert und mit leichten Kopfschmerzen quàle ich
mich gegen 10 Uhr aus dem Bett, lande irgendwann am Rechner
und schalte ein

.

. und am Anmeldebildschirm geht die Maus NICHT!!!!!


Ich hab keinen Bock, einen neuen Rechner zu kaufen und den
ganzen Kàse von vorne durchzumachen! Wohin dann mit dem
alten, der ja eigentlich super (AMD 64-bit, dual core,
3 GB RAM, 1.5 TB Platten, ...) und nicht total kaputt ist?
Ich hasse sowas! Ich will einfach nur ein stabil laufendes
System, damit ich produktiv arbeiten kann!

Idee! Da gammelt ein ungenutztes Window$ XP auf einer kleinen
Partition dieses Rechners. Das starte ich, um zu sehen,
ob das Maus/Tastaturproblem auch dort auftritt. Gesagt,
getan - unter Window$ geht's! Naja, wenigstens für solche
Tests ist XP gut.

Im BIOS hatte ich übrigens schon wàhrend der Reparaturnacht
die (unter Linux reglose) Tastatur nutzen können, es schien
also ein Systemproblem zu sein, kein Hardwareproblem.

Nach diesem Abstecher zu Window$ boote ich wieder Linux
und siehe da - jetzt geht auch unter Linux wieder alles.

Auch heute, am Tag 1 nach dem GAU und nach dem erneuten
Hochfahren des Systems funktioniert alles wie erwartet.

Einige Dinge beunruhigen mich aber:

* Warum funktionierten Tastatur und [USB-]Maus plötzlich
nicht mehr unter Linux?

* Warum wurden die frisch eingeschalteten USB-Backupplatten
nicht mehr registriert und nicht mehr nutzbar ins System
gehàngt?

* Warum funktionierten Tastatur und [USB-]Maus problemlos
unter Window$?

* Warum half eine Linux-Neuinstallation zunàchst, allerdings
nur bis zum nàchsten Booten?

* Warum funktionierten Tastatur/Maus erst wieder unter Linux,
nachdem ich mich unter Window$ angemeldet habe und mich
dort von deren Funktionsfàhigkeit überzeugen konnte?

* Also: Wie kommt es zu einem Ausfall des gesamten USB-Systems
(Maus, ext. Platten, Wacom-Tablett) "einfach so" und ganz
zwischendurch und auch noch boot-resistent?

Viele Fragen wichtige Fragen .. noch wichtiger:
Ich hàtte gerne Antworten!

Interessant ist, dass das ursàchliche Problem auf meinem
Produktionssystem entstand, das ich konservativ, nach der
Pràmisse "never change a running system", pflege. Das hàtte
ich wirklich nicht gedacht.

Der gestrige Tag war dann wieder "fast normal", denn hier
und da musste (und muss) ich mich an Änderungen in der
Software gewöhnen. Mein wesentlicher Workflow ist aber
voll nutzbar, das beruhigt. Zum Abend dann ein kleines
Spielchen (Shisen, das mit den bunten Steinchen, die man
verbinden muss) und schließlich der verwegene Versuch,
eine Video-DVD zu kopieren - was mir unter Linux [out of
the box] noch nie gelungen war.

Beides funktionierte reibungslos und so kam's, dass ich
mir gegen Mitternacht den "Bàllzisch" - von der Kopie,
nicht vom Original - zur Hàlfte anschaute. Was für ein
Genuss!

Schöne Grüße aus den Alpen,
Frank
 

Lesen sie die antworten

#1 Daniel Fett
03/04/2008 - 17:19 | Warnen spam
schrieb:
[viel.]

* Warum funktionierten Tastatur und [USB-]Maus plötzlich
nicht mehr unter Linux?

* Warum wurden die frisch eingeschalteten USB-Backupplatten
nicht mehr registriert und nicht mehr nutzbar ins System
gehàngt?

* Warum funktionierten Tastatur und [USB-]Maus problemlos
unter Window$?

* Warum half eine Linux-Neuinstallation zunàchst, allerdings
nur bis zum nàchsten Booten?

* Warum funktionierten Tastatur/Maus erst wieder unter Linux,
nachdem ich mich unter Window$ angemeldet habe und mich
dort von deren Funktionsfàhigkeit überzeugen konnte?

* Also: Wie kommt es zu einem Ausfall des gesamten USB-Systems
(Maus, ext. Platten, Wacom-Tablett) "einfach so" und ganz
zwischendurch und auch noch boot-resistent?



Hmm... ich tippe auf ein externes Geràt, was am gleichen Bus hàngt, und
irgendwie einen "Zustand" hat. Tablett und Maus schließe ich daher mal
aus, aber die Platten klingen verdàchtig. Ich hab hier eine externe
Festplatte, die, nachdem man sie unter Windows benutzt hat (aber nur
dann!), den Neustart des Rechners (bleibt im Bios hàngen) blockiert.
Also vielleicht mal testweise entfernen.

HTH,
Daniel

Ähnliche fragen