Euro Zeichen auf der Konsole

29/10/2007 - 19:20 von Michael Wagner | Report spam
Hallo zusammen,

ich habe hier auf einem Debian unstable mit Kernel 2.6.22-2-k7
(Distributionskernel) ein seltsames Phànomen.

Ich kann auf den Konsolen 1-6 ganz normal das € Zeichen und das Zeichen
für ¢ eingeben. Wenn ich mich auf einer dieser Konsolen per ssh auf
einem meiner anderen Rechner einlogge, funktioniert die Ausgabe auch so
wie es sein soll.

Allerdings hab ich mir zusàtzlich die Konsolen 9-11 für weitere
Terminals in der /etc/inittab freigeschaltet. Auf diesen Konsolen kann
ich die beiden Zeichen aber nicht eingeben. Sondern es erscheint ein "ò"
statt dem €. Das ¢ Zeichen funktioniert auch dort.

Das komische ist jetzt, das wenn ich mich von den Konsolen 9-11 auf
einem meiner anderen Rechner einlogge, ich auch dort dann auch keinen €
eingeben kann.

Das Problem kann auch nicht der X-Server sein. Denn auch wenn ich ohne X
hochfahre, ist es bei den Konsolen das Gleiche. 1-6 gehen die Zeichen,
9-11 nicht. Es ist zwar nichts so Wichtiges, aber es nervt mich halt
ungemein.

Vielleicht kann das ja hier einer nachvollziehen und weiss, woran ich
drehen muss.

Michael
 

Lesen sie die antworten

#1 Martin Heimes
29/10/2007 - 21:30 | Warnen spam
Michael Wagner schrieb:

Ich kann auf den Konsolen 1-6 ganz normal das ? Zeichen und das Zeichen
für ¢ eingeben. Wenn ich mich auf einer dieser Konsolen per ssh auf
einem meiner anderen Rechner einlogge, funktioniert die Ausgabe auch so
wie es sein soll.



dein Newsreader deklariert charset=iso-8859-1 - und erst wenn ich meinem
sage er soll iso-8859-15 benutzen sehe ich das Eurozeichen oben.
Martin

Ähnliche fragen