evolution-exchange-2.12.1 wird nicht

01/11/2007 - 22:43 von Andreas Lattka | Report spam
Hallo Leute,

Ich wollte heute evolution-exchange-2.12.1 übersetzen und bekomme dabei
Fehler und habe im Ergebnis leider keine Verbindung zum Exchange Server
mehr. Die Übersetzung bricht ab bei:

/usr/local/lib/evolution/2.12/libeutil.so: warning: warning: mktemp()
possibly used unsafely; consider using mkstemp()
/usr/bin/ld: warning: libkrb5.so.8, needed by /usr/local/lib/libexchange-
storage-1.2.so, may conflict with libkrb5.so.23
/usr/bin/ld: warning: libcrypto.so.4, needed by /usr/local/lib/
libexchange-storage-1.2.so, may conflict with libcrypto.so.5
/usr/bin/ld: warning: libroken.so.8, needed by /usr/local/lib/libexchange-
storage-1.2.so, may conflict with libroken.so.19
/usr/bin/ld: warning: libgssapi.so.8, needed by /usr/local/lib/
libexchange-storage-1.2.so, may conflict with libgssapi.so.2
/usr/lib/libkrb5.so.8: undefined reference to `copy_octet_string'
/usr/lib/libgssapi.so.8: undefined reference to `length_len'
gmake[2]: *** [evolution-exchange-storage] Fehler 1
gmake[2]: Leaving directory `/usr/ports/mail/evolution-exchange/work/
evolution-exchange-2.12.1/storage'
gmake[1]: *** [all-recursive] Fehler 1
gmake[1]: Leaving directory `/usr/ports/mail/evolution-exchange/work/
evolution-exchange-2.12.1'
gmake: *** [all] Fehler 2
*** Error code 2

Stop in /usr/ports/mail/evolution-exchange.

Ich hatte schon mal versucht heimdal gegen krb5 zu ersetzen, da heißen
die Bibliotheken aber anders, z.b. libgssapi_krb5.so, so dass das auch
nicht weiter half.

Danach versuchte ich die Uralt-Pakete von Evolution zu installieren
(mittels pkgadd -r), da fehlt dann aber scrollkeeper, was ja vor Kurzem
gerade ersetzt wurde durch rarian.

Hat irgend jemand eine Ahnung wie evolution-exchange jetzt übersetzt
werden kann?

Mein System ist
FreeBSD viggo.lattka.de 6.2-RELEASE FreeBSD 6.2-RELEASE #2: Mon Jan 29
19:15:59 CET 2007 root@viggo.lattka.de:/usr/obj/usr/src/sys/VIGGO
i386
, in der /etc/make.conf steht nichts in Bezug auf Kerberos.

Vielen Dank schon mal!

Neoline
 

Lesen sie die antworten

#1 Joseph Terner
02/11/2007 - 11:40 | Warnen spam
Andreas Lattka wrote:
Hallo Leute,

Ich wollte heute evolution-exchange-2.12.1 übersetzen und bekomme dabei
Fehler und habe im Ergebnis leider keine Verbindung zum Exchange Server
mehr. Die Übersetzung bricht ab bei:

/usr/local/lib/evolution/2.12/libeutil.so: warning: warning: mktemp()
possibly used unsafely; consider using mkstemp()
/usr/bin/ld: warning: libkrb5.so.8, needed by /usr/local/lib/libexchange-
storage-1.2.so, may conflict with libkrb5.so.23
/usr/bin/ld: warning: libcrypto.so.4, needed by /usr/local/lib/
libexchange-storage-1.2.so, may conflict with libcrypto.so.5
/usr/bin/ld: warning: libroken.so.8, needed by /usr/local/lib/libexchange-
storage-1.2.so, may conflict with libroken.so.19
/usr/bin/ld: warning: libgssapi.so.8, needed by /usr/local/lib/
libexchange-storage-1.2.so, may conflict with libgssapi.so.2
/usr/lib/libkrb5.so.8: undefined reference to `copy_octet_string'
/usr/lib/libgssapi.so.8: undefined reference to `length_len'
gmake[2]: *** [evolution-exchange-storage] Fehler 1
gmake[2]: Leaving directory `/usr/ports/mail/evolution-exchange/work/
evolution-exchange-2.12.1/storage'
gmake[1]: *** [all-recursive] Fehler 1
gmake[1]: Leaving directory `/usr/ports/mail/evolution-exchange/work/
evolution-exchange-2.12.1'
gmake: *** [all] Fehler 2
*** Error code 2

Stop in /usr/ports/mail/evolution-exchange.

Ich hatte schon mal versucht heimdal gegen krb5 zu ersetzen, da heißen
die Bibliotheken aber anders, z.b. libgssapi_krb5.so, so dass das auch
nicht weiter half.

Danach versuchte ich die Uralt-Pakete von Evolution zu installieren
(mittels pkgadd -r), da fehlt dann aber scrollkeeper, was ja vor Kurzem
gerade ersetzt wurde durch rarian.

Hat irgend jemand eine Ahnung wie evolution-exchange jetzt übersetzt
werden kann?



Im großen und ganzen wie immer: _Alle_ Abhàngigkeiten des Ports neu
übersetzen.

ciao, Joseph

Ähnliche fragen