Ex2k7 fügt leeren Text bei Mails hinzu

17/07/2009 - 10:32 von Michael S | Report spam
Hallo,

ich habe ein Problem mit eMails, seitdem wir einen Exchange 2007 Server
verwenden. Es ist ein SP1 Standard unter Win 2008 x64 Standard. Die Clients
laufen unter Win XP mit Outlook 2003 SP3.
Einige Mails gehen an ein System das Anhànge selbstàndig extrahiert.
Von der Technik des Empfàngers habe ich folgende Info erhalten:
Es ist so implementiert, dass es diesen direkt als base64-Anhang entpackt.
Die "fehlerhaften" Mails haben zusàtzlich zum Anhang einen leeren Textbereich
und kommen somit als Multipart-Mail an. Dabei kommt es zu Fehlern beim
herausschneiden des Anhangs.

Die Sache mit dem leeren Textbereich ist das merkwürdige. Denn es dürfte
keinen Textbereich geben, da dieser leer sein muss. Die Mail besteht nur aus
Sender- und Empfàngerdaten, Betreff und Anhang, aber hat keinen Inhalt.
Hier scheint Exchange 2007 aber irgendetwas zu veràndern, aber ich bin bis
jetzt nicht dahinter gekommen was da los ist.

Auf einem Exchange 2003 Server der auch an das System mailt besteht das
Problem hingegen nicht. Genauso ist es wenn man die Mail über POP3
verschickt. Somit bleibt als Übeltàter nur der Exchange 2007.
Doch kann ich dieses Verhalten irgendwie beeinflussen?

Gruß, Michael
 

Lesen sie die antworten

#1 Steinsdorfer Walter
17/07/2009 - 13:06 | Warnen spam
Hi,

ich habe ein Problem mit eMails, seitdem wir einen Exchange 2007 Server
verwenden. Es ist ein SP1 Standard unter Win 2008 x64 Standard. Die
Clients
laufen unter Win XP mit Outlook 2003 SP3.
Einige Mails gehen an ein System das Anhànge selbstàndig extrahiert.
Von der Technik des Empfàngers habe ich folgende Info erhalten:
Es ist so implementiert, dass es diesen direkt als base64-Anhang entpackt.
Die "fehlerhaften" Mails haben zusàtzlich zum Anhang einen leeren
Textbereich
und kommen somit als Multipart-Mail an. Dabei kommt es zu Fehlern beim
herausschneiden des Anhangs.

Die Sache mit dem leeren Textbereich ist das merkwürdige. Denn es dürfte
keinen Textbereich geben, da dieser leer sein muss. Die Mail besteht nur
aus
Sender- und Empfàngerdaten, Betreff und Anhang, aber hat keinen Inhalt.
Hier scheint Exchange 2007 aber irgendetwas zu veràndern, aber ich bin bis
jetzt nicht dahinter gekommen was da los ist.

Auf einem Exchange 2003 Server der auch an das System mailt besteht das
Problem hingegen nicht. Genauso ist es wenn man die Mail über POP3
verschickt. Somit bleibt als Übeltàter nur der Exchange 2007.
Doch kann ich dieses Verhalten irgendwie beeinflussen?



kommen denn wirklich alle Anhànge als Base64 an?
Rein interessehalber: Was genau macht ihr mit dem System? Übrigens:
Sharepoint kann das auch, da muß ich mich noch nicht mal um die Kodierung
der Dateien kümmern.

Viele Grüsse aus München

Walter Steinsdorfer
MVP Exchange Server
www.exusg.de
http://msmvps.com/blogs/wstein

Ähnliche fragen