[Excel 2003] Summenprodukte addieren

14/01/2012 - 18:22 von Ralf Brinkmann | Report spam
Ich habe mal wieder ein Spezialproblem mit dem wunderbaren
SUMMENPRODUKT:

In einem Einsatzplan will ich mir eine Übersicht darüber anlegen,
wieviele Stunden die Mitarbeiter im jeweiligen Monat geleistet haben.

In der ersten Spalte steht das Datum, dahinter wiederholt sich viermal
nebeneinander der Block Name1, Name2, Stunden, weil es sich immer um
Zweierteams handelt, die die gleichen Stunden zusammen arbeiten, aber
immer unterschiedlich gemischt sein können. Also

Datum Name1 Name2 Stunden Name1 Name2 Stunden ...
01.01.
...
31.12.

Es kann also vorkommen, dass ein Name eines Mitarbeiters mehrmals in den
verschiedenen Spalten in einem Monat auftaucht, auch mehrmals an einem
Tag.

Nun ist es zwar relativ problemlos möglich, mit SUMMENPRODUKT gleich in
einem Rutsch über den gesamten Bereich der 4 "Blöcke" festzustellen, wie
oft jemand im Januar, Februar, Màrz usw. gearbeitet hat.

Wenn ich aber die Anzahl der Stunden feststellen will, müsste ich meiner
Meinung nach die Summenprodukt-Formel für jeden Block separat
wiederholen und die Ergebnisse addieren. Also:
=SUMMENPRODUKT(...)+SUMMENPRODUKT(...)+SUMMENPROIDUKT(...)+SUMMENPRODUKT(...).

Oder geht das auch irgendwie eleganter, kürzer? Die Formeln werden sonst
ziemlich lang.

Gruß, Ralf
Windows XP Home SP3
Opera 11.61 - 1236
The Bat! Pro 5.0.24
 

Lesen sie die antworten

#1 Claus Busch
14/01/2012 - 18:35 | Warnen spam
Hallo Ralf,

Am Sat, 14 Jan 2012 18:22:22 +0100 schrieb Ralf Brinkmann:

Datum Name1 Name2 Stunden Name1 Name2 Stunden ...
01.01.
...
31.12.



probiers mal so:
=SUMME((B1:Z1="Name1")*B2:Z366)
und schließe die Eingabe mit STRG+Shift+Enter ab (Array-Formel)


Mit freundlichen Grüßen
Claus Busch
Win XP Prof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen