excel 2007 vba: Bezüge per Makro verändern

16/04/2009 - 11:17 von stefan schneider | Report spam
Hallo,

kann man Bezüge in Formeln per Makro veràndern?
Konkret habe ich folgendes Problem:
In Spalte A1:A10 habe ich diverse Bezüge stehen:
A1: =MITTELWERT('P4'!$AE$2:$AE$3000)
A2: =MITTELWERT('P4'!$AP$2:$AP$3000)
etc

In Spalte B1:B10 sollte nun stehen:

A1: =MITTELWERT('P4'!$Ag$2:$Ag$3000)
A2: =MITTELWERT('P4'!$Aq$2:$Aq$3000)
etc

Es sollte also irgendwie möglich sein, die Bezüge der markierten Zellen
(hier z.B. B1:B10) um x Spalten zu verschieben, mal können es 2, mal 5
Spalten sein etc.

Kann jemand weiterhelfen?

Danke

stefan
 

Lesen sie die antworten

#1 Andreas Killer
16/04/2009 - 12:24 | Warnen spam
On 16 Apr., 11:17, stefan schneider wrote:

kann man Bezüge in Formeln per Makro veràndern?


Na klar.

In Spalte A1:A10 habe ich diverse Bezüge stehen:
A1: =MITTELWERT('P4'!$AE$2:$AE$3000)
etc
In Spalte B1:B10 sollte nun stehen:
A1: =MITTELWERT('P4'!$Ag$2:$Ag$3000)
etc


1.) Kopier alle Formeln von Hand von A1:A10 nach B1:B10
2.) Starte den Makrorecorder
3.) Markiere B1:B10
4.) Suche nach AE, ersetze durch AG, alle ersetzen
5.) Stop den Makrorecorder
6.) Makro anpassen oder den Rest von Hand durch Suchen/ersetzen
erledigen ;-)

Andreas.

Ähnliche fragen