EXCEL 2010: nur bestimmte Wochentage eines Monats anzeigen (ohne VBA)

15/01/2014 - 21:13 von Helmut | Report spam
Hi,
ich möchte (ohne VBA) folgendes realisieren:

Eingabe: Jahr, Monat (1-12) und Wochentag (0-6)
Ausgabe : Liste aller Daten, die dem gew. Wochentag entsprechen

Z.B. alle Donnerstage im Januar 2014, also
2.01.14
9.01.14
16.01.14
23.01.14
30.01.14

Natürlich kann ich mit WENN() und WOCHENTAG() die nicht
passenden Tage ausblenden, aber wie bekomme ich
eine *lückenlose* Liste (d. h. frei von Leerzellen) wie oben?

Gruß
Helmut
 

Lesen sie die antworten

#1 Claus Busch
15/01/2014 - 21:34 | Warnen spam
Hallo Helmut,

Am Wed, 15 Jan 2014 21:13:02 +0100 schrieb Helmut:

Eingabe: Jahr, Monat (1-12) und Wochentag (0-6)
Ausgabe : Liste aller Daten, die dem gew. Wochentag entsprechen

Z.B. alle Donnerstage im Januar 2014, also
2.01.14
9.01.14
16.01.14
23.01.14
30.01.14



in A1 das Jahr, In B1 den Monat als Zahl, in C1 den Wochentag als Zahl
(1 für Montag bis 6 für Samstag)

Dann für den ersten Wochentag des Monats (z.B. in D1):
ÚTUM(A1;B1;1)-WOCHENTAG(DATUM(A1;B1;1)-C1;2)+7
für die Folgetage dann in D2:
=WENN(MONAT(D1+7)=MONAT(D1);D1+7;"")
und runterziehen bis Leerzelle erscheint


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen