Excel dringende Hilfe benötigt: Suche und Zuordnung in einem Intervall

26/08/2015 - 14:12 von goekhan.ruezgar | Report spam
Hallo Zusammen,

habe ein Problem in Excel etwas zu zuordnen, wàre für Ideen und Hilfestellungen Dankbar.

Ich habe zwei Arbeitsblàtter:

Arbeitspapier 1:

Gebiet Postleitzahl Straße Von Bis Bezirk
Mitte 28201 Meyerstr. 1 99 1
Mitte 28201 Meyerstr. 2 98 2
Mitte 28201 Meyerstr. 101 9999 3
Süd 28199 Martinistr. 1 8 4
Süd 28199 Martinistr. 2 12 5

Arbeitsplatz 2:

Postleitzahl Straße HNr Bezirk Gebiet
28201 Meyerstr. 1 ? ?
28201 Meyerstr. 2
28201 Meyerstr. 3
28201 Meyerstr. 4
28201 Meyerstr. 5
28201 Meyerstr. 6
28201 Meyerstr. 7
28201 Meyerstr. 8
28201 Meyerstr. 9
28201 Meyerstr. 10
28201 Meyerstr. 11
28201 Meyerstr. 12
28201 Meyerstr. 13
28201 Meyerstr. 14
28201 Meyerstr. ...
28201 Meyerstr. n
28199 Martinistr. 1
28199 Martinistr. 2
28199 Martinistr. 3
28199 Martinistr. 4
28199 Martinistr. 5
28199 Martinistr. 6
28199 Martinistr. 7
28199 Martinistr. 8
28199 Martinistr. 9
28199 Martinistr. 10
28199 Martinistr. 11
28199 Martinistr. 12
28199 Martinistr. 13
28199 Martinistr. 14
...


Im Arbeitsblatt2 sollen die jeweiligen Bezirke und Gebiete aus Arbeitsblatt1 den einzelnen Adressen zugeordnet werden.

Für eine Lösung wàre ich Dankbar.

Viele Grüße

Rüzgar
 

Lesen sie die antworten

#1 Claus Busch
26/08/2015 - 14:47 | Warnen spam
Hallo,

Am Wed, 26 Aug 2015 05:12:46 -0700 (PDT) schrieb
:

Gebiet Postleitzahl Straße Von Bis Bezirk
Mitte 28201 Meyerstr. 1 99 1
Mitte 28201 Meyerstr. 2 98 2
Mitte 28201 Meyerstr. 101 9999 3
Süd 28199 Martinistr. 1 8 4
Süd 28199 Martinistr. 2 12 5

Arbeitsplatz 2:

Postleitzahl Straße HNr Bezirk Gebiet
28201 Meyerstr. 1 ? ?
28201 Meyerstr. 2
28201 Meyerstr. 3
28201 Meyerstr. 4
28201 Meyerstr. 5
28201 Meyerstr. 6
28201 Meyerstr. 7
28201 Meyerstr. 8
28201 Meyerstr. 9
28201 Meyerstr. 10
28201 Meyerstr. 11
28201 Meyerstr. 12
28201 Meyerstr. 13
28201 Meyerstr. 14
28201 Meyerstr. ...
28201 Meyerstr. n
28199 Martinistr. 1
28199 Martinistr. 2
28199 Martinistr. 3
28199 Martinistr. 4
28199 Martinistr. 5
28199 Martinistr. 6
28199 Martinistr. 7
28199 Martinistr. 8
28199 Martinistr. 9
28199 Martinistr. 10
28199 Martinistr. 11
28199 Martinistr. 12
28199 Martinistr. 13
28199 Martinistr. 14
...

Im Arbeitsblatt2 sollen die jeweiligen Bezirke und Gebiete aus Arbeitsblatt1 den einzelnen Adressen zugeordnet werden.



für das Gebiet kannst du in F2 schreiben:
=INDEX(Tabelle1!A:A;VERGLEICH(A2;Tabelle1!$B$1:$B$1000;0))

Aber für den Bezirk ist keine Logik vorhanden, womit man eine
universelle Formel zum Herunterziehen erstellen könnte. So musst du für
jede Straße eine gesonderte Formel erstellen.
Für die Meyerstraße würde dies funktionieren:
=WENN(C2>100;3;WENN(REST(C2;2)=1;1;2))


Mit freundlichen Grüßen
Claus
Vista Ultimate / Windows7
Office 2007 Ultimate / 2010 Professional

Ähnliche fragen