Excel: Feld = NICHTLEER ??

11/09/2009 - 18:45 von pelikan | Report spam
Hallo Ihr

Ich suche den Ausdruck in MS Excel (2004), mit welcher eine Formel nur
dann abgearbeitet wird, wenn eine Zelle nicht leer (oder alternativ auch
leer) ist. Also bspw.

=WENN(A1=NICHTLEER;"ResultatA";"ResultatB)

Ich habe bei anderer Gelegenheit mit >0 gearbeitet, das hat
funktioniert. Jetzt aber geht das nicht, und zwar aus folgendem Grund:
Es geht um die Punkteberechnung aus einem Fussballspiel. Sieg 3, Remis 0
oder Verloren 0 Punkte. Meine Formel dazu im Moment lautet

=WENN(D4>F4;3;WENN(D4ô;1;WENN(D4<F4;0)))

Das Problem: Steht in den beiden Feldern D4 und F4 gar nichts drin, weil
dieses Spiel noch nicht gespielt wurde, ergibt diese Formel trotzdem 1
Punkt für beide Teams, weil der Inhalt der beiden Felder identisch.

Es müsste nun eine weitere WENN-Funktion vorgeschaltet werden, die alles
folgende nur dann auslöst, wenn F4 einen Inhalt hat, also NICHTLEER ist.
Wir formuliert man das in Excel, hat da jemand einen Tipp?

Roger
 

Lesen sie die antworten

#1 i20pwq5alprub49
11/09/2009 - 19:08 | Warnen spam
R. Pellaton wrote:

Hallo Ihr

Ich suche den Ausdruck in MS Excel (2004), mit welcher eine Formel nur
dann abgearbeitet wird, wenn eine Zelle nicht leer (oder alternativ auch
leer) ist. Also bspw.

=WENN(A1=NICHTLEER;"ResultatA";"ResultatB)



Probier doch mal etwas wie

=WENN(A1<>"";"ResultatA";"ResultatB)
=WENN(A1=#NV;"ResultatA";"ResultatB)

Mit so einer Geschichte kann Excel schon mal einen in den Wahnsinn
treiben, weill man nicht heraus findet, wie Excel das meint.

Da kann man auch fündig werden, mit sehr ungewöhnlichen Formeln:
<www.excelformeln.de/formeln.html>

Ähnliche fragen