Excel Inhalte transponieren

12/09/2007 - 15:14 von Michael E. | Report spam
Liebe Excel-Group,
ich habe folgendes Problem.
Von einer Uni habe ich eine Liste von Kongressbeitràgen (Nummern) und
Autoren bekommen. Die Datei sieht so aus:
Spalte A Spalte B Spalte C Spalte D
Zeile 1 Poster001 Müller, E. Maier, F.
Zeile 2 Poster002 Huber, E.
...
Zeile 300 Poster300 Karl, L. Müller, F. Huber, E.

Übersetzt bedeutet das z.B für den ersten Kongressbeitrag, daß die Autoren
Müller und Maier den Beitrag "Poster 001" verfasst haben. Ein Poster kann bis
zu 7 Autoren haben. Die Autoren können mehrere Posterbeitràge verfaßt haben.

Der Verlag will nun ein Verzeichnis, das alle Autoren enthalt mit Angabe der
Kongressbeitràge, sortiert nach dem Nachnamen der Autoren,
also z.B
Huber E. Poster002, Poster 300
Karl, M. Poster300
Maier, F. Poster001
Müller, E. Poster001
Müller, F. Poster300

Frage: geht das überhaupt mit Excel (Excel2003 unter XP SP2)? Wenn ja, wie?
Ich freue mich schon über Eure Vorschlàge
Vielen Dank und herzliche Grüße
Michael Ernst
 

Lesen sie die antworten

#1 Alexander Wolff
12/09/2007 - 15:35 | Warnen spam
Spalte A Spalte B Spalte C Spalte D
Zeile 1 Poster001 Müller, E. Maier, F.
Zeile 2 Poster002 Huber, E.
...
Zeile 300 Poster300 Karl, L. Müller, F. Huber, E.

[soll werden zu]

Huber E. Poster002, Poster 300
Karl, M. Poster300
Maier, F. Poster001
Müller, E. Poster001
Müller, F. Poster300





1) Setze A+B, A+C, A+D als Zweispaltenbereiche untereinander (in A:B)
und lösche danach die Spalten ab C
2) Sortiere nach B und vertausche danach A und B
3) Arbeite nun mit folgenden herunterzukopierenden Formeln in C und D:
C2: £¢
D2: =WENN(C1;D1&",";)&B2
4) Autofiltere C = FALSCH
(Für den Autofilter brauchst Du Feldbezeichner in Zeile 1)
5) Kopiere das Filtrat an seine endgültige Stelle (mit Strg-C Eingabe)
Moin+Gruss Alexander - MVP für MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen