Excel Problem: Wenn-Funktion mit Oder-Funktion verschachtelt und Argumentsuche im Bereich mit Text

23/03/2012 - 08:29 von Christoph Lubkowitz | Report spam
Moin NG,

ich sitze hier an einer -so dachte ich wenigstens- einfachen Abfrage in
Excel. Um das Problem zu verdeutlichen habe ich eine ganz einfache
Tabelle aufgebaut.

A1: "einmal"
B1: "zweimal"

Mit einer Wenn-Abfrage wollte ich herausfinden, ob im Bereich A1:B1
"einmal" oder "zweimal" vorkommt.
Meine Formel dazu lautet:

=WENN(ODER(A1:B1="einmal";A1:B1="zweimal");"wahr";"falsch")

Excel meldet "#WERT!"
Wenn ich auf "fx" vor der Formal drücke, wird kein Fehler in den
einzelnen Teilen der Formel angezeigt und auch die Teilergebnisse sind
richtig.

Hat jemand eine Idee?

Danke und Gruß,

Christoph
 

Lesen sie die antworten

#1 Claas Thede
23/03/2012 - 09:25 | Warnen spam
Hallo Christoph,

Am 23.03.2012 08:29, schrieb Christoph Lubkowitz:
[Excel]
A1: "einmal"
B1: "zweimal"

Mit einer Wenn-Abfrage wollte ich herausfinden, ob im Bereich A1:B1
"einmal" oder "zweimal" vorkommt.
Meine Formel dazu lautet:

=WENN(ODER(A1:B1="einmal";A1:B1="zweimal");"wahr";"falsch")



welche Version nutzt Du?

In Excel 2007 sieht das ganze zunàchst so aus, als ob es wie gewünscht
funktioniert, allerdings scheinen die Bereichsvergleiche (A1:B1="...")
problematisch zu sein. Z.B. làsst sich die skurile Situation
herbeiführen, dass der ODER-Term in der Zelle ausgeführt FALSCH ergibt,
wàhrend das Fenster "Funktionsargumente" als Ergebnis WAHR ermittelt.

Folgende Workarounds sollten auch bei àlteren Excel-Versionen funktionieren:

a) die zu prüfenden Zellen über VERKETTEN aneinanderhàngen, dann mit
FINDEN darin suchen. ISTZAHL liefert direkt eine logische Aussage über
das Ergebnis und fàngt im negativen Fall den Fehler ('#WERT!') ab:
=ISTZAHL(FINDEN("einmal";VERKETTEN(A1;B1)))
Nachteil: auch Wortteile werden "gefunden", also z.B. "einm" oder
"malzwei"; das erfordert ggf. eine weitergehende Eingabeprüfung und/oder
ein Trennzeichen zwischen den verketteten Zellen. Zudem arbeitet
VERKETTEN nicht mit Bereichen, die Zellen müssen also einzeln angegeben
werden.

b) Lege neben oder unter Deinem zu prüfenden Bereich eine (versteckte)
Spalte/Zeile an, die in allen parallelen Zellen eine 1 enthàlt, z.B. in
Deinem Beispiel in A2 und B2. Dann kannst Du SUMMEWENN benutzen:
=SUMMEWENN(A1:B1;"einmal";A2:B2) bzw.
=WENN(SUMMEWENN(A1:B1;"einmal";A2:B2)>0;WAHR;FALSCH)


HTH & Gruß
Claas

Ähnliche fragen