excel rechnet falsch gibt es eine Lösung ?

13/03/2008 - 11:41 von Walther | Report spam
Hallo NG!

Leider ist in excel

2800,24 - 2442 - 293,2 - 65,04 = -2,13163E-13
(A1 - B1 - C1 - D1 = F1 )

gibt es da einen Patch / Fix ?

Danke für jeden Tipp.

(ahh ja : 2002 SP3 )

Liebe Grüße aus dem windigen München

Walther
 

Lesen sie die antworten

#1 Robert Gelbmann
13/03/2008 - 12:10 | Warnen spam
Hallo Walther!

"Walther" schrieb ...

2800,24 - 2442 - 293,2 - 65,04 = -2,13163E-13
(A1 - B1 - C1 - D1 = F1 )

gibt es da einen Patch / Fix ?



Nein, da es sich hier um eine allgemeine Rechenproblematik bezüglich
Dezimalzahlen einerseits und - intern verwendeten - Binàrzahlen
andererseits handelt. Da muss Excel (wie auch andere Programme) einfach
irgendwo runden. (Excel führt ja auch "nur" 15 signifikante Stellen.)

Im konkreten Fall entspricht die Abweichung -0,21 Billionstel!
Abgesehen davon, dass dieser Fehler wohl nirgends einen echten Einfluss
auf das Endergebnis in den ersten 8 (oder so) Nachkommastellen haben
dürfte und somit irrelevant sein dürfte, kannst du als Abhilfe
selbstverstàndlich jedes Rechenergebnis durch die Tabellenfunktion
RUNDEN() jagen; z. B. auf 8 Nachkommastellen genau:

=RUNDEN(A1-B1-C1-D1;8)

Insbesondere wàre dies dann bei Vergleichen (ob das Ergebnis auch
wirklich 0 ist etc.) anzuraten.

In der Hoffnung geholfen zu haben, verbleibe ich mit einem leisen


Servus aus Wien,
-Robert Gelbmann-

I solemnly swear that I'm up to no good.

Ähnliche fragen