Forums Neueste Beiträge
 

Excel2k7: Bedingte Formatierung - Längenproblem?

22/09/2009 - 18:03 von Erik Harren | Report spam
Moin zusammen!

Ich versuche mich gerade daran, eine bedingte Formatierung aus Excel2k7
für Excel2003 zu begradigen, welches bekanntlich nur drei Bedingungen
verarbeiten kann.

Ich habe vier Bedingungen, wobei ich nur eine zu einer Oder-Formel
zusammenfassen möchte:

Die Einzelbedingungen funktionieren einwandfrei:

Bist Du ein Feiertag?
=SVERWEIS(DATUM(JAHR(Jahreszahl);SVERWEIS($A$68;Monate;2;FALSCH);$A70);Feiertage;1;FALSCH)

Bist Du ein Samstag oder ein Sonntag?
=ODER(WOCHENTAG(DATUM(JAHR(Jahreszahl);SVERWEIS($A$68;Monate;2;FALSCH);$A70);2)=6;WOCHENTAG(DATUM(JAHR(Jahreszahl);SVERWEIS($A$68;Monate;2;FALSCH);$A70);2)=7)

Wunschergebnis: Bist Du ein Feiertag, Samstag oder Sonntag?
- jeht abba nicht, ich erhalte nur Feiertage korrekt angezeigt.

=ODER(WOCHENTAG(DATUM(JAHR(Jahreszahl);SVERWEIS($A$68;Monate;2;FALSCH);$A70);2)=6;WOCHENTAG(DATUM(JAHR(Jahreszahl);SVERWEIS($A$68;Monate;2;FALSCH);$A70);2)=7;SVERWEIS(DATUM(JAHR(Jahreszahl);SVERWEIS($A$68;Monate;2;FALSCH);$A70);Feiertage;1;FALSCH))

Selbst wenn ich die Formel verkürze mittels einer Hilfsspalte gehts net:

=ODER($AC70=1;SVERWEIS(DATUM(JAHR(Jahreszahl);SVERWEIS($A$68;Monate;2;FALSCH);$A70);Feiertage;1;FALSCH))

Der Fàhler wird mal wieder davor sitzen, ich weiß nur noch nicht wo
(außer den 80 cm vor dem Bildschirm).

Gruß,
Erik.
 

Lesen sie die antworten

#1 Dietmar Vollmeier
22/09/2009 - 18:55 | Warnen spam
Servus Erik!

*Erik Harren* schrieb am 22.09.2009 um 18:03 Uhr...
Ich versuche mich gerade daran, eine bedingte Formatierung aus Excel2k7
für Excel2003 zu begradigen, welches bekanntlich nur drei Bedingungen
verarbeiten kann.

[...]



Kannst du uns vielleicht einen Auszug deiner Tabelle zur Verfügung
stellen. So blicke ich bei deinen Fomeln nicht ganz durch ;-)
und tschüss | Man soll sich nicht über die Dinge àrgern, denn denen ist
Didi | das völlig egal.

Ähnliche fragen